Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Wheels and Tires

Wheels and Tires Wheels and Tires - Everything from brakes to sprockets


Reply
 
LinkBack Thread Tools Display Modes
April 6th, 2018, 10:50 PM   #1
Member
 
Joined: May 2005
From: New Zealand

Posts: 60
Thanks: 1

I Ride:
Front brake problem

My 09 Fe450 has been sitting unused for about 18 months... yes I know thats a crime in itself, but lots of reasons

Anyway when I go to ride it, I notice the brake lever has no resistance and obviously not front brakes at all.
I try bleeding the brakes, but no improvement.
I decided the master cylinder needs a new kit, so replaced that and bleed it up but still no pressure.
I assume it must be the slave cylinder/caliper assembly?
Any suggestions on what I should be looking at in particular?
kiwiberger is offline  
 
April 7th, 2018, 01:45 AM   #2
Senior Member
 
Alan's Avatar
 
Joined: Jul 2016
From: Australia, Beechworth, Vic.

Posts: 463
Thanks: 235

I Ride: when I can which isn't often enough. FX450, FE570
Pressure bleed from the bottom up.
Alan is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Wheels and Tires

Tags
brake, front, problem



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: WANTED!! Looking for New Front Brake HAND BRAKE CYLINDER DaBergman Classifieds 0 February 23rd, 2018 07:47 PM
Front Brake = no brake light . . . . . . FlatTrack Electrical 4 August 13th, 2014 05:30 AM
Rear Brake problem and Brake Fluid Question jaminlove Wheels and Tires 3 May 5th, 2013 10:45 PM
FE570 2011 front brake problem linnell Wheels and Tires 3 February 28th, 2012 01:02 PM
Front brake problem MEDOGROCKET Mechanical 12 May 5th, 2008 11:56 PM


Facebook Twitter Google+ RSS Feed