Husaberg
Go Back   Husaberg Forum > Lobby > New Users

New Users Post up here and introduce yourself!


Reply
 
LinkBack Thread Tools Display Modes
May 1st, 2017, 09:25 PM   #1
Junior Member
 
Joined: May 2017
From: Canada

Posts: 2
Thanks: 0

I Ride:
TPS issues

Having issues with TPS or so it seams. FI light flashes 6 short and 2009 570fe bogs intermittently, sometimes completely stalls. problem comes and goes, have replaced my TPS and have set with multi-meter. runs fantastic for a while then problem always comes back. Any suggestions?
Batzy73 is offline  
 
May 1st, 2017, 11:54 PM   #2
Senior Member
 
Joined: Jul 2011
From: vermont

Posts: 189
Thanks: 31

I Ride: 2011 fe390
Sounds like a loose or damaged connector or frayed wire if it intermittently blinks. Make sure the connector "clicks" into tps. Tough to get at with fingers w/out tank off.
fe390vt is offline  
May 1st, 2017, 11:59 PM   #3
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,539
Thanks: 417

I Ride: Husaberg FE501e 2003
those 6 flashes are for the battery aren't they?

taffy
Taffy is offline  
May 3rd, 2017, 05:27 PM   #4
Junior Member
 
Joined: May 2017
From: Canada

Posts: 2
Thanks: 0

I Ride:
Manual say 6 flashes=TPS
Batzy73 is offline  
May 3rd, 2017, 11:46 PM   #5
Senior Member
 
FE350's Avatar
 
Joined: Apr 2014
From: Chilliwack, BC, Canada

Posts: 686
Thanks: 252

I Ride: 2014 FE350, Beautiful Blonde
6 short are TPS. Does it randomly run shitty or will it continue so you can test when running poorly? If it does then back probe the TPS harness at the connector and test voltages when running poorly. Chances are you have a intermittent open in the circuit and then it faults. I would pull and move wires around while running bike to see if I can make a change in the way it runs. Sorta a quick route. Then work on the harness when found if fault happens. Most likely it will if its a intermit open in the harness. Hope this helps.
FE350 is offline  
Reply

  Husaberg Forum > Lobby > New Users

Tags
bogging, fuel, issues, throttle position sensor, tps



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
FE 400 issues wiktor Mechanical 12 June 21st, 2018 01:07 AM
choke issues nikolz12 Fuel 9 March 23rd, 2015 09:07 PM
Ignition issues 2003berg Electrical 2 May 15th, 2014 11:12 PM
fx 450 issues? sigh..... jgilbert164 Mechanical 4 February 18th, 2013 04:51 AM
We are not alone.....FI issues. Barshoe Fuel 12 January 13th, 2012 04:26 AM


Facebook Twitter Google+ RSS Feed