Husaberg
Go Back   Husaberg Forum > Lobby > New Users

New Users Post up here and introduce yourself!


Reply
 
LinkBack Thread Tools Display Modes
May 10th, 2014, 06:08 PM   #1
Djb
Junior Member
 
Joined: May 2014
From: Australia

Posts: 8
Thanks: 0

I Ride:
Angry No spark after rebuild

Hello all, newbie here looking for assistance on my sparkless 09 570.
Had the bike apart for a new piston & conrod bearings, after reassembly have no spark.
Have checked all the wiring & replaced the spark plug but still nothing.
Does anyone know the resistance and/or output from the stator & ignition pulse generator so they can be checked?
Any assistance would be appreciated.
Djb is offline  
 
May 11th, 2014, 09:51 AM   #2
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 1,089
Thanks: 506

I Ride: 3x FE570
From the manual:

jon andersson is offline  
May 13th, 2014, 02:13 AM   #3
Djb
Junior Member
 
Joined: May 2014
From: Australia

Posts: 8
Thanks: 0

I Ride:
Thank you very much for this information.
Can you tell me what manual it is from and if it is available online.
Thanks & regards
DJB.
Djb is offline  
May 13th, 2014, 03:03 AM   #4
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 1,089
Thanks: 506

I Ride: 3x FE570
It's the service manual and you can buy it from a dealer. But cheapest is to search for it on this forum and download it
jon andersson is offline  
May 15th, 2014, 06:23 PM   #5
Djb
Junior Member
 
Joined: May 2014
From: Australia

Posts: 8
Thanks: 0

I Ride:
Two problems???

According to these measurements, both my coil and spark plug cap are bad???
Im a bit surprised.
Not sure how an engine rebuild could cause either of these components to fail, let alone both?
Has anyone else experienced coil & cap failure?
Just looking for some confirmation before parting with the cash!
Djb is offline  
May 15th, 2014, 07:43 PM   #6
Senior Member
 
Joined: Apr 2014
From: Alameda CA

Posts: 101
Thanks: 10

I Ride: 05 FE 650, 11 FE 570
Here ya go, welcome aboard.

Owners Manual
http://husaberg.org/attachments/serv...eu-usa-aus.pdf

Repair Manual
http://husaberg.org/attachments/serv...eu-usa-aus.pdf

Spare Parts Manual
http://husaberg.org/attachments/serv...saberg-570.pdf

Wiring Diagrams
http://husaberg.org/attachments/serv...-570-eu-uk.pdf

Good luck with the electrical issue. Not an expert here, but it sounds big enough to be something obvious.


Steve

Last edited by sgomes; May 15th, 2014 at 08:06 PM.
sgomes is offline  
May 19th, 2014, 03:47 PM   #7
Djb
Junior Member
 
Joined: May 2014
From: Australia

Posts: 8
Thanks: 0

I Ride:
Steve,
Thanks a bunch for the manuals. I did some searches on here to no avail so thanks!
After fiddling with my multimeter a bit more, it seems that my coil & spark plug cap are OK.
Don't know if it is my multimeter or coil/cap but it is difficult to get a reading.
Good news is I don't need the coil the shop got in for me.
Bad news is I still have NO SPARK.
any assistance would be greatly appreciated.
David.
Djb is offline  
May 19th, 2014, 04:27 PM   #8
Djb
Junior Member
 
Joined: May 2014
From: Australia

Posts: 8
Thanks: 0

I Ride:
If the timing was way out would it still spark, just at the wrong time?
Djb is offline  
May 19th, 2014, 05:49 PM   #9
Senior Member
 
Joined: Jul 2011
From: vermont

Posts: 189
Thanks: 31

I Ride: 2011 fe390
no spark

keep tracing it back from the coil towards the battery til you get an electrical reading...guessing you forgot to plug something in...possibly the kokusan.. take the tank back off and check...
fe390vt is offline  
May 20th, 2014, 05:39 PM   #10
Djb
Junior Member
 
Joined: May 2014
From: Australia

Posts: 8
Thanks: 0

I Ride:
The kokusan is plugged in.
The coil leads directly back to the kokusan so nothing more to trace back there.
Checked the wire for continuity - ok.
Coil input is 280mV 50mA which although measures very repeatably seems too low to do anything.
Unfortunately the bike has been modified for safari work which has included removal of the FI/diagnostic light. I am unaware of its function but am surprised nobody has asked if it is showing any faults.
Are there any other faults/disconnected components that would result in suppressing the spark, possibly to protect the engine??
Getting really desperate. Want to go riding next week and really dont want to wheel it into the shop half pulled apart.
Appreciate any ideas.
DJB.
Djb is offline  
Reply

  Husaberg Forum > Lobby > New Users

Tags
rebuild, spark



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fe 570 rebuild Whitestarz Mechanical 4 February 23rd, 2012 10:47 AM
650 SM 02 rebuild jampe Mechanical 1 April 13th, 2011 01:59 PM
FX 470 rebuild mito Mechanical 2 August 2nd, 2009 10:25 PM
2002 501 weak spark or no spark bergtime Electrical 3 December 11th, 2008 02:44 AM
Rebuild or not rebuild - that is the question! Coastie Mechanical 20 August 9th, 2007 01:17 PM


Facebook Twitter Google+ RSS Feed