Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Mechanical

Mechanical Mechanical Forum - spinning bits and gyrating bobs


Reply
 
LinkBack Thread Tools Display Modes
September 14th, 2019, 07:12 PM   #1
Member
 
Joined: Jul 2019
From: Ontario

Posts: 43
Thanks: 1

I Ride: 97 KTM SX 250 2 stroke and 04 husaberg 450fe
Why don't my lights work?

I notice on my 04 Fe 450 it don't have the controls for the high-low beam and signals do I need those controles for the light to work or should it still work without the left side switches ? My light is hooked up it doesn't seem to turn on tho. The previous owner removed just the signals and switches for the signals and lights but everything alts is there

Last edited by Chrisfe450canadian; September 14th, 2019 at 07:15 PM.
Chrisfe450canadian is offline  
 
September 15th, 2019, 03:23 AM   #2
Senior Member
 
fe600racer's Avatar
 
Joined: Jun 2004
From: australia

Posts: 398
Thanks: 15

I Ride:
Does the horn work......or is the whole control switch box gone and light just wired on?
fe600racer is offline  
September 15th, 2019, 04:12 AM   #3
Member
 
Joined: Jul 2019
From: Ontario

Posts: 43
Thanks: 1

I Ride: 97 KTM SX 250 2 stroke and 04 husaberg 450fe
The main control switches are gone for the horn and signals and high/low beam just the switches to turn the dash on are still there , headlight is still wired up
Chrisfe450canadian is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Mechanical

Tags
lights, work



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
lights ! wrghtlk Electrical 0 November 21st, 2014 08:46 AM
Sem stator differences lights vs no lights Bergini Electrical 8 March 26th, 2013 04:28 AM
-03 FE 650: El. start + lights, horn doesn't work fridenscky Electrical 7 January 21st, 2013 10:58 AM
fe 450 09 no lights wardy Electrical 7 August 16th, 2011 10:46 PM
lights mick1hussy Electrical 0 May 26th, 2011 11:35 AM


Facebook Twitter Google+ RSS Feed