Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Mechanical

Mechanical Mechanical Forum - spinning bits and gyrating bobs


Thanks Tree20Thanks
Reply
 
LinkBack Thread Tools Display Modes
May 11th, 2019, 04:02 PM   #1
Junior Member
 
Joined: May 2019
From: newfoundland

Posts: 17
Thanks: 8

I Ride:
2010 fe 390 problems

hey all! new to the forum and also a new berg owner. was on a ride today and somthing popped and the bike started to knock. Instantly i shut it off. my first thought was the cam chain tensioner so I am gonna order a new one none the less.. but if I try to start or even crank over the bike a bit there is nothing. just a click. this leads me to think something else happened.. any thoughts? was hoping to get it started to get the sound clip for help. and in the same go, no the head light and tail light are gone.. or they could have been gone prior but they were working on last ride. where do I start..lol thanks in advance
yetman is offline  
 
May 12th, 2019, 04:20 PM   #2
Junior Member
 
Joined: May 2019
From: newfoundland

Posts: 17
Thanks: 8

I Ride:
so i have begun the process of getting ready to teardown and figure this out. so far i have discovered you can not crank it manually all the way around.. goes one way and stops and then goes the other way and same thing. any thoughts? i know i prob have to fully tear it down just tryin to narrow the search
yetman is offline  
May 12th, 2019, 04:46 PM   #3
Senior Member
 
tourist's Avatar
 
Joined: Nov 2012
From: Iceland

Posts: 2,379
Thanks: 811

I Ride: 1 Berg, 1 Zook
Aw man, that sucks. Hope we can figure this out quick

So there has to be something in the combustion chamber right? Something got sucked in, or a valve dropped?

If you have a bore scope I’d have a peek down there, but I’d mostly just go for having a look in the head and then popping the head off and having a look down the cylinder.
Thanks from yetman
tourist is online now  
May 12th, 2019, 05:36 PM   #4
Junior Member
 
Joined: May 2019
From: newfoundland

Posts: 17
Thanks: 8

I Ride:
ya there has to be something stuck.. i can crank it manually half way and it hits hard.. almost like the connecting rod broke and the piston is stuck half way. hauling the head off tomorrow id say.. sad thing is it was my second ride on it
yetman is offline  
May 13th, 2019, 03:50 AM   #5
Senior Member
 
tourist's Avatar
 
Joined: Nov 2012
From: Iceland

Posts: 2,379
Thanks: 811

I Ride: 1 Berg, 1 Zook
Damn :/ This is quite rare with these :’(
tourist is online now  
May 13th, 2019, 12:57 PM   #6
Junior Member
 
Joined: May 2019
From: newfoundland

Posts: 17
Thanks: 8

I Ride:
just gettin home from work here now.. prep time and then diving in.. i will update as i go along as I more than likely will have a few questions along the way. fortunately the fella i bought it from has every record and manual. both hard copy and disk.. and like most riders a few buddies willing to help.. wish me luck folks..
yetman is offline  
May 13th, 2019, 06:11 PM   #7
Junior Member
 
Joined: May 2019
From: newfoundland

Posts: 17
Thanks: 8

I Ride:
ok so i have the engine out.. I never dropped a valve... head bolt are in good so i need to wait til tomo to get my neighbour to hold it to get leverage... updates tomorrow..
Thanks from tourist and Cali
yetman is offline  
May 14th, 2019, 05:19 PM   #8
Junior Member
 
Joined: May 2019
From: newfoundland

Posts: 17
Thanks: 8

I Ride:
ughhhh. so due the the fly wheel not being able to crank the full way i can not get tdc. thoughts and suggestions? when i rotate clockwise i can build up some compression and then it will release as it roll it counter clockwise until it locks.
yetman is offline  
May 14th, 2019, 08:31 PM   #9
Member
 
cwidova's Avatar
 
Joined: Feb 2014
From: Victoria, Australia

Posts: 35
Thanks: 5

I Ride: 2010 FE390
Can you remove the rockers and spark plug on the motor and turn it over then? Just thinking that maybe one of the cams has jumped a tooth and the valves are opening at the wrong time and stopping it from doing a full turn....but only a possibiltiy, can still be something else too
Thanks from tourist

Last edited by cwidova; May 14th, 2019 at 08:34 PM.
cwidova is offline  
May 15th, 2019, 04:18 PM   #10
Junior Member
 
Joined: May 2019
From: newfoundland

Posts: 17
Thanks: 8

I Ride:
found the prob. valve stem seal blew up, fell into cylnder, piston hit head smash said bits.. new head, piston, gaskets, and valves..
yetman is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Mechanical

Tags
2010, 390, problems



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting problems 570 2010 Gezwindespoed Mechanical 12 October 26th, 2014 03:08 AM
Stator problems 2010 FX 450 jeffs2200 Electrical 5 May 12th, 2014 05:59 PM
2010 Fe450 fuel problems... i think? Janu Lategan Fuel 2 April 25th, 2012 08:03 AM
clutch problems 2010 390 bergy Mechanical 6 November 8th, 2011 04:07 AM
Newbee problems with 2010 fe570 wthemechanic Husaberg 11 March 14th, 2011 12:22 PM


Facebook Twitter Google+ RSS Feed