Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Mechanical

Mechanical Mechanical Forum - spinning bits and gyrating bobs


Thanks Tree3Thanks
  • 1 Post By Taffy
  • 2 Post By Krainczy 777
Reply
 
LinkBack Thread Tools Display Modes
March 27th, 2019, 11:46 PM   #1
Junior Member
 
Joined: Mar 2019
From: Hungary

Posts: 5
Thanks: 2

I Ride: HBG 470fe
Full throttle with pure backfires

So after solving my cooling problem now a new thing came up. A month ago when I was reving my bike for fun or just to show off it didnt have any problem(had no backfires), running normally, reving up normally. But like a week ago when I do the same, even if while moving, pulled clutch and full throttle, just spitting fire as fuck, almost blowing my exhaust off and feels like it wanna die "like it gets too much fuel?" (spitting fire and not reving up to the top). I didnt change anything on the carb, nor the valve clerances. Didnt touch a thing on the bike that could be linked with this problem. Also while pinning it in any gear, on the highest rpm making the same blows.

Any idea what causes this? Its a 2004fe 470 with mikuni carb. The bike runs normally on idle, starting up easily and powerfull still. Hope you guys can help me out.

Youtube video link:

Cheers,
Krainczy

Last edited by Krainczy 777; March 27th, 2019 at 11:49 PM.
Krainczy 777 is offline  
 
March 28th, 2019, 04:42 AM   #2
Senior Member
 
fe600racer's Avatar
 
Joined: Jun 2004
From: australia

Posts: 358
Thanks: 11

I Ride:
Stator needs replacing.
fe600racer is offline  
March 28th, 2019, 11:02 PM   #3
Junior Member
 
Joined: Mar 2019
From: Hungary

Posts: 5
Thanks: 2

I Ride: HBG 470fe
Okay so first of all, I thought theres some leaks on the gasket or on the carb, tested out with sprays where could the air flow in but everything fits just fine. Had only one hole on the engine breather hose (maybe fresh air went inside the engine from there?) oil was coming out from there too. Also one more thing, that theres 3 screw holding the stator, now from 3 screws one was broken, other two was loose. Replaced the broken one and tighten them up but didnt test it yet, could this be my problem or do I need to change the stator still?
Krainczy 777 is offline  
March 29th, 2019, 12:32 AM   #4
Junior Member
 
Vandor501's Avatar
 
Joined: Jan 2019
From: Sweden

Posts: 19
Thanks: 1

I Ride: '08 FE450e Supermoto & '02 CR250R
Depends if its been damaged or not, try and see if it fixed the problem first. Otherwise I would recommend cleaning the carb since its likely that you not getting a rich enough mix.

Skickat från min SM-G950F via Tapatalk
Vandor501 is offline  
March 29th, 2019, 12:33 AM   #5
Junior Member
 
Vandor501's Avatar
 
Joined: Jan 2019
From: Sweden

Posts: 19
Thanks: 1

I Ride: '08 FE450e Supermoto & '02 CR250R
Originally Posted by Vandor501 View Post
Depends if its been damaged or not, try and see if it fixed the problem first. Otherwise I would recommend cleaning the carb since its likely that you not getting a rich enough mix.

Skickat från min SM-G950F via Tapatalk
By that I mean see that its not clogged or that you get the right mixture according to weather etc

Skickat från min SM-G950F via Tapatalk
Vandor501 is offline  
March 29th, 2019, 01:17 AM   #6
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,539
Thanks: 417

I Ride: Husaberg FE501e 2003
tight valves but more likely a blocked pilot jet. then there's the stator; as said above. take the measurements for that?

2,750ohms for the red to black and 165ohms for the green to black.
Taffy
Thanks from Vandor501
Taffy is offline  
April 1st, 2019, 10:47 AM   #7
Junior Member
 
Joined: Mar 2019
From: Hungary

Posts: 5
Thanks: 2

I Ride: HBG 470fe
So it seems like my stator was way too loose, and that caused this backfire problem on max revs. 100% sure becasue from now on tested 2 days and works just like factory new

Thank you all for helping and tips.

Cheers,
Krainczy
Thanks from Rainerio and Vandor501
Krainczy 777 is offline  
April 1st, 2019, 11:45 AM   #8
Junior Member
 
Vandor501's Avatar
 
Joined: Jan 2019
From: Sweden

Posts: 19
Thanks: 1

I Ride: '08 FE450e Supermoto & '02 CR250R
Originally Posted by Krainczy 777 View Post
So it seems like my stator was way too loose, and that caused this backfire problem on max revs. 100% sure becasue from now on tested 2 days and works just like factory new

Thank you all for helping and tips.

Cheers,
Krainczy
Nice to hear! Always nice to have a firespitting monster of a berg tho..

Skickat från min SM-G950F via Tapatalk
Vandor501 is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Mechanical

Tags
backfires, full, pure, throttle



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
11 fx 450 backfires kfralick73 Husaberg 9 November 30th, 2017 02:36 PM
Intermittently dies on hard/full throttle RogerB39 Electrical 6 September 12th, 2016 04:58 PM
09 FE 570 Decel Popping when 3/4 and Full Throttle to Zero sanddanw Fuel 0 July 30th, 2012 08:10 PM
holding back on full throttle emo30emo Husaberg 2 February 18th, 2010 11:25 AM
How many kms until I can go full throttle with my FS650E Anonymous94832 Husaberg 0 July 2nd, 2008 06:17 AM


Facebook Twitter Google+ RSS Feed