Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Mechanical

Mechanical Mechanical Forum - spinning bits and gyrating bobs


Thanks Tree3Thanks
Reply
 
LinkBack Thread Tools Display Modes
March 27th, 2019, 06:19 AM   #11
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,731
Thanks: 456

I Ride: Husaberg FE501e 2003
well it sounds like the original jetting yes but a 182MJ is ridiculously rich.

go back to how it was, check the slide and plate are the right way up. get an extended pilot screw and adjust that.

it really is simple!

Taffy
Taffy is offline  
 
March 29th, 2019, 07:33 AM   #12
Junior Member
 
Joined: Aug 2018
From: Watsonville, ca

Posts: 10
Thanks: 0

I Ride: FE 550
Taffy!

Taffy- I was able to get in touch with the original owner of the bike. He said it was your jetting kit installed in the bike (which ran great up until it suddenly changed.
I found my notes from the tear down and cleaning:
idle jet 40
start jet 85? (its hard to see the stamp exactly)
needle jet 165 (now changed to 172)
idle-air jet 45
main air jet 155
The needle is brass it looks like but I don't have a size from it.

If this sounds like your kit for a FE550 then I need to know what setting I need for the clip on the needle. My hope, is to clean it again tonight and restore to your kit settings.

Sound rational?
chriscaris is offline  
March 29th, 2019, 08:40 AM   #13
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,731
Thanks: 456

I Ride: Husaberg FE501e 2003
go back to the 165MJ.
fit a 40PJ.
clip 8.
PS to suit.

I know deep down it was mine. you didn't even notice that you had 9 clip positions!

if it ran fine before then it can run fine again!

all that can suddenly happen is that the slide plate cracked and broke off or it took in a piece of sand etc and blocked off one of the air routes in.

Taffy
Taffy is offline  
March 31st, 2019, 01:01 AM   #14
Senior Member
 
Joined: Dec 2011
From: Brisbane Australia

Posts: 143
Thanks: 93

I Ride: FE650
Originally Posted by chriscaris View Post
Bike seems fine other than under load in first gear so I was thinking more about carb issue than electrical

That’s usually what coils do. Faulty Coils will start fine, run fine and then start breaking down under load and will seem almost like a fuel problem. Fooled many a mechanic.

Also check the vent hoses on the carb.
Thanks from Vandor501

Last edited by Hoosaberg; March 31st, 2019 at 01:41 AM.
Hoosaberg is offline  
May 5th, 2019, 07:25 AM   #15
Junior Member
 
Joined: Apr 2017
From: Nova Scotia, Canada

Posts: 3
Thanks: 2

I Ride: 2006 fe450e
Hey there, when I bought my beaten and abused 2003 fe450e, it would kick start ok (well as ok as those beasts can be kicked), but after warming up, as soon as I gave it throttle, it would stall out pulling away. The only way to pull away was to throttle it up high and pop the clutch.

The problem = accelerator pump (rubber diaphragm) = in the carburetor! It was all cracked and leaking. The way the pump works, it gives the bike an extra squirt of gas when first rolling on the throttle as there is not enough air flow to carry the regular volume of gas through (from the vids I reviewed). I ordered the part very cheap from my KTM shop. Since I have the carb coming off, I decided to order new jets and needle and bowl gasket for shits and giggles (all very cheap). Striped carb as per the vids on the tube, lots of carb cleaner. That fixed the problem, and I did very easy Keihin FRC O ring modification as well while I was in there (vids on youtube).

Hope this helps. And don't fear taking the carb off and opening it up, the vids on youtube for FRC Keihin are very well done.
Thanks from Rainerio

Last edited by wildbillmacpherson; May 5th, 2019 at 07:31 AM.
wildbillmacpherson is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Mechanical

Tags
1st, bogs, carb, dies, taking



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
570 is taking a dive! TomTom Ride Reports 10 February 27th, 2017 07:19 AM
Taking the plate off desertthumperx Husaberg 1 August 12th, 2012 03:25 PM
2002 FC 550/ cranks fine/bogs and dies as soon as I gas it olpace Fuel 2 June 29th, 2012 07:01 AM
ok im taking the plunge!! McMucker Husaberg 16 December 30th, 2005 03:47 PM
Taking a SEM second look... volvonut Husaberg 10 September 18th, 2005 10:14 AM


Facebook Twitter Google+ RSS Feed