Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Mechanical

Mechanical Mechanical Forum - spinning bits and gyrating bobs


Reply
 
LinkBack Thread Tools Display Modes
April 30th, 2010, 10:52 AM   #1
JW
Senior Member
 
Joined: Jan 2008
From: Netherlands

Posts: 127
Thanks: 0

I Ride:
HELP please: 09 engine stalling after 30 mins or so

my 09 450 has done 160 hours, I did all the nessecary work almost exactly as rhe manual says.

now, after 30 -45 mins of riding all sorts of trails, the engine wants to stop for no reason, although it occus when i pull the throttle qoute firmly. It feels as if the carb is giving problems, but hey, there is no carb... I seem to be alble to keep the engine runing by... more gas.. stragen huh? i checked all the fuell filters, no problems there. after 30 secs to one minute the problem is gone, and back 15 mins later. The problem also occurs on the race track, and a lot more severe, so much that riding becomes dangerous.

testing is difficuls as the problem anly occurs after 45 mins or more...

any ideas? thnx jw
JW is offline  
 
April 30th, 2010, 10:59 AM   #2
Moderator
 
berger's Avatar
 
Joined: Apr 2002
From: Phoenix Arizona

Posts: 3,152
Thanks: 10

I Ride: 2010 FX450
Re: HELP please: 09 engine stalling after 30 mins or so

Fuel cap vent?
berger is offline  
April 30th, 2010, 12:24 PM   #3
Moderator
 
Joined: Oct 2002
From: Sunland, CA

Posts: 3,117
Thanks: 19

I Ride:
Re: HELP please: 09 engine stalling after 30 mins or so

Is your bike totally stock? If not what mods have you made?

No FI flash codes? If not is the bulb still good in your FI light? IE does it come on momentarily when you start your bike?

Just a stab in the dark here............... Based on what you are describing, I wonder if the coil or solenoid that fires your injector is having some kind of thermal failure, as in an open coil. It also sounds like a bad stator too, again related to a high thermal condition where an open circuit occurs.

Have you checked the fuel pressure?
DaleEO is offline  
May 1st, 2010, 12:47 AM   #4
JW
Senior Member
 
Joined: Jan 2008
From: Netherlands

Posts: 127
Thanks: 0

I Ride:
Re: HELP please: 09 engine stalling after 30 mins or so

thnx for the answers, the bike is all stock, but it did start a few days after i disconnected my fall-over-sensor in marokko. It started on the highway, allmost like clockwork every 10 minutes it felt like there was no fuell reaching the engine. i can just keep the bike unning when it goes fast enough, but on the racetrack i dies. and then starts without a problem. If i'm able to keep it running, it tries to shut doen again when i pull the trottle hard, and this goesd on for 5 secs. an the its gone again...

how can i check the fuel pressure? the cap vent is clear, thats not it allthough that is what the syptoms look like. no flash codes, but for the one that signals the fall-over sensor is down.
JW is offline  
May 1st, 2010, 06:17 AM   #5
Moderator
 
Joined: Oct 2002
From: Sunland, CA

Posts: 3,117
Thanks: 19

I Ride:
Re: HELP please: 09 engine stalling after 30 mins or so

So, you have disconnected the roll over sensor? And you get a flash code that the roll over sensor is down?

Why did you disconnect the roll over sensor?

If you suspect the roll over sensor is bad, replace it and plug it in.

If there was nothing wrong with the roll over sensor in the first place, plug it back in and I bet your problems will be solved.

Fuel pressure: It's one of the maintenance checks you are supposed to do every 30 hours or so. The dealer has a set up to put an pressure gauge in line from your fuel pump line to the throttle body.
DaleEO is offline  
May 2nd, 2010, 01:12 AM   #6
JW
Senior Member
 
Joined: Jan 2008
From: Netherlands

Posts: 127
Thanks: 0

I Ride:
Re: HELP please: 09 engine stalling after 30 mins or so

Originally Posted by DaleEO
So, you have disconnected the roll over sensor? And you get a flash code that the roll over sensor is down?

Why did you disconnect the roll over sensor?

If you suspect the roll over sensor is bad, replace it and plug it in.

If there was nothing wrong with the roll over sensor in the first place, plug it back in and I bet your problems will be solved.

Fuel pressure: It's one of the maintenance checks you are supposed to do every 30 hours or so. The dealer has a set up to put an pressure gauge in line from your fuel pump line to the throttle body.
ok, thnx, i will go to the dealer then, never checked the fuel opressure.

I was in a dune rally in marocco last month when the sensor went bad, every dune i tried to ride triggered the sensor, so the only option was to disconnect it. i'll have it reparid/replaced, and see if that helps

thnx for the thinking!
JW is offline  
May 2nd, 2010, 07:15 AM   #7
Moderator
 
Joined: Oct 2002
From: Sunland, CA

Posts: 3,117
Thanks: 19

I Ride:
Re: HELP please: 09 engine stalling after 30 mins or so

No problem, I'm sure that once it's replaced it will all be sorted.

"When everything that is probable has been eliminated, what ever remains, however improbable has to be the answer"--Sherlock Holmes
DaleEO is offline  
May 17th, 2010, 11:23 PM   #8
JW
Senior Member
 
Joined: Jan 2008
From: Netherlands

Posts: 127
Thanks: 0

I Ride:
Re: HELP please: 09 engine stalling after 30 mins or so

for the record and to complete this post: it turns out that the computer found the problem. The fuelpump sometimes lacks juice, maybe becouse it is making mass or a cable break somewhere. we'll fix this along with the new sensor.
JW is offline  
May 18th, 2010, 03:15 AM   #9
Junior Member
 
Joined: Jul 2009
From: The Neherlands

Posts: 28
Thanks: 0

I Ride:
Re: HELP please: 09 engine stalling after 30 mins or so

Also check the cable behind the airfilter for good connection.
During the Baja Saxonia I could not start the engine anymore.

By replacing the airfilter the night before I accidentally disconnected the connection to the fuelpomp.

Had a lot of fun after I found the problem

Mosseltje is offline  
May 18th, 2010, 04:59 AM   #10
Member
 
Joined: Feb 2010
From: Tehachapi, California

Posts: 39
Thanks: 0

I Ride:
Re: HELP please: 09 engine stalling after 30 mins or so

Great picture!!
boanders is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Mechanical

Tags
engine, mins, stalling



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stalling help. MrX Mechanical 16 April 15th, 2013 11:32 PM
nothing but stalling ............HELP Braddenning Fuel 1 November 16th, 2012 06:32 AM
Stalling BelgiqueBasterd Husaberg 10 November 3rd, 2009 03:29 PM
Stalling engine 501 Cheesehead Fuel 7 September 4th, 2008 10:41 PM
back up and running!... well for 10 mins :( McMucker Husaberg 8 February 25th, 2006 08:13 AM


Facebook Twitter Google+ RSS Feed