Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Mechanical

Mechanical Mechanical Forum - spinning bits and gyrating bobs


Reply
 
LinkBack Thread Tools Display Modes
February 8th, 2010, 01:00 AM   #1
Senior Member
 
Joined: Feb 2009
From: Birdwood South Australia

Posts: 272
Thanks: 11

I Ride: 70 degree fe450 2012 & Aprilia Dorsoduro
Delo colour

Just rebuit my motor and decided to run Delo for the first time after starting it up the oil must airiate real bade almost looks like water in oil after leaving it a while colour changes back to normal any one else seen this?
birdwoodburg is offline  
 
February 9th, 2010, 12:21 AM   #2
Senior Member
 
Joined: Mar 2009
From: Cyprus

Posts: 131
Thanks: 0

I Ride:
Re: Delo colour

Hey there what oil were you running before?
Robg187 is offline  
February 9th, 2010, 02:20 AM   #3
Member
 
Joined: Sep 2009
From: Adelaide, South Oz

Posts: 84
Thanks: 0

I Ride:
Re: Delo colour

I used Delo 400 for the first time recently and also noticed this. Was very, very wierd. Looked like it was full of bubbly water.
aardvark is offline  
February 9th, 2010, 11:02 AM   #4
Senior Member
 
Joined: Jan 2009
From: Brisbane, Australia

Posts: 235
Thanks: 15

I Ride: 2012 FE 570, 2004 950 Adventure, 99 YZF 400, 1982 FXR Harley Davidson
Re: Delo colour

Birdwood,
I run Delo in my 550 and don't notice this issue at all...have you drained the oil in question ? If so did the next lot of oil do it...I wonder if you've got a coolant leak internally.

The oil and fluid may seperate again after the motor stops mixing it up but this usually sends you oil milky white

Just an idea

Pilot
520pilot is offline  
February 9th, 2010, 11:19 AM   #5
Senior Member
 
cypher's Avatar
 
Joined: Mar 2006
From: mid-wales, uk

Posts: 1,778
Thanks: 3

I Ride: Bikes
Re: Delo colour

rebuilt my 450 last year and even though it wasn't delo in it, I to though 'oh shit' as the first time it started the oil looked like it had water in it. After a while it settled down and cleared.

been fine since
cypher is offline  
February 9th, 2010, 01:52 PM   #6
Senior Member
 
bushmechanic's Avatar
 
Joined: Jun 2007
From: south east WA Australia

Posts: 3,812
Thanks: 1130

I Ride: 2008 700FK, 2002 628FST
Re: Delo colour

does that when its cold

after a good hard ride it looks fine
bushmechanic is offline  
February 9th, 2010, 10:24 PM   #7
Senior Member
 
Joined: Feb 2009
From: Birdwood South Australia

Posts: 272
Thanks: 11

I Ride: 70 degree fe450 2012 & Aprilia Dorsoduro
Re: Delo colour

Was using motul 10w50 and yes it has settled now looks a normal colour. The oil was drained after i noticed it straight away ,this was after warm up after rebuild. Let both settle no water must be a first time thing maybe. Even so looks different running in sight glass than the motul ever did.
birdwoodburg is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Mechanical

Tags
colour, delo



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Delo 100 or Delo 400 Synthetic? HeyJohnnyPark Mechanical 10 August 26th, 2009 04:05 PM
What Colour Helmet? steve Gear 3 April 19th, 2009 12:19 PM
plug colour Taffy Electrical 28 August 6th, 2007 02:51 PM
Colour Scheme? kez Husaberg 10 March 13th, 2006 03:05 PM
Colour (Color) Obmar Tech 2 October 31st, 2005 04:43 PM


Facebook Twitter Google+ RSS Feed