Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Reply
 
LinkBack Thread Tools Display Modes
November 18th, 2020, 06:31 PM   #1
Junior Member
 
Joined: Nov 2020
From: Santa Fe, NM

Posts: 7
Thanks: 4

I Ride:
My '99 FE501 is running cold

I took my '99 FE501 out for a mileage test last weekend, and I did 59 miles per gallon averaging 50 mph. It was around 50F temps. My motor at those speeds was averaging between 113F - 116F. At those cold temps, it felt rich, and down on power. I'd sit for 5 minutes at idle to get it up to 175F, and of course, it was more responsive, and happier. It needs a thermostat (for at least 160F). Is there any kind of thermostat that can be installed? Maybe one that goes "in-line"?
jmosher is offline  
 
November 18th, 2020, 08:22 PM   #2
Member
 
Joined: Jul 2019
From: southwest

Posts: 91
Thanks: 16

I Ride: 99 FE501e, FX600e, FC501
You can get a number of different inline thermostats that would work, I am surprised it is running so cool though...where are you measuring the temp from?
heidenberg is offline  
November 19th, 2020, 02:55 AM   #3
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 16,263
Thanks: 539

I Ride: Husaberg FE501e 2003
JMosher

yes I think we can do something for you! I have factory thermostats for the later models and the T junction.

As for jetting....
I'd go to my facebook page and watch the videos about ignition timing. also, you need to re-mark your flywheel.

then I'd think about jetting!

I do an "easystart" kit that repalces all the worn parts. I also do a jetting kit for the 2001-2003 501cc. Now, rolling that out to the next obvious bikes wouild be the 1999-2000 501s that had the same everything bar exhaust. That is a performance kit which you'd be impressed by and is called the 'Berg Booster' kit.

use the names I used in searching for stuff.

cheers

Taffy
Attached Thumbnails
My '99 FE501 is running cold-copy-40600010.jpg   My '99 FE501 is running cold-ignition-timing-diagram.jpg  

Last edited by Taffy; November 19th, 2020 at 02:59 AM.
Taffy is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
cold, fe501, running



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does a 2013 FE501 require a battery to stay running dodger66 Electrical 5 July 29th, 2014 04:52 PM
No start, 99 FE501 Running out of ideas... Kablazzie Mechanical 13 May 5th, 2014 10:33 AM
10 fe 570 wont stay running cold/ sputters ,stalls 1Trak Mind Fuel 3 December 9th, 2012 05:22 AM
09 450 cold running problems Johnniep Mechanical 2 February 2nd, 2012 12:52 PM
Cold start ok...Cold Clutch?? 08fe450 zachhill Mechanical 12 February 5th, 2010 11:23 AM


Facebook Twitter Google+ RSS Feed