Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Thanks Tree3Thanks
  • 2 Post By Peter570
  • 1 Post By pjk380
Reply
 
LinkBack Thread Tools Display Modes
July 18th, 2018, 04:02 AM   #1
Junior Member
 
Joined: Apr 2015
From: Riverina NSW Australia

Posts: 19
Thanks: 5

I Ride: 2011 FE 570, Yamaha IT 490
Simpson Desert tour

Well gents, just took the 570 for my first real adventure. Have been doing a fair bit round the kosiosko region of southern NSW. Two weeks ago myself and fourteen other bikes including anotner 2011 FE570 crossed the Simpson desert from east to west and then back again. (1450k's) What a brilliant bike to ride. The more i ride it the better it gets.
I have two questions. One is ive got around 8 thousand k's on the clock, no work on the engine other than regular servicing. Is there something extra i should be doing.
Second is i have a small weep of coolant coming from the tell tale on the water pump. Is there a common problem that causes this.
Thanks from plumbbob and tourist
Peter570 is offline  
 
July 26th, 2018, 09:07 AM   #2
Member
 
pjk380's Avatar
 
Joined: Sep 2012
From: Yorba Linda, CA

Posts: 30
Thanks: 3

I Ride: 09 FE 450, KTM 380/SmartCarb
The coolant leak is common. The weep hole is in a direct line to get water, dirt - roost from the front wheel. That puts debris in there and accelerates the wear of the water pump seal. See "keep crud out of the weep hole" thread.

Keep the crud out of the weep hole

I pulled mine apart a couple years ago as mine began leaking too. I replaced the water pump seal, oil seal & impeller. My impeller was stuck on the shaft and I destroyed it trying to remove it. I found only a little bit of debris in there so it only takes a little bit to ruin the seals. I installed some tubing as noted in the thread so debris can no longer get in there. No more leaking.

09 570 wtaer pump seal.

See above for directions to install the water pump seal. It seems the factory and even the shop manual shows incorrect installation.
Thanks from tourist

Last edited by pjk380; July 26th, 2018 at 09:24 AM.
pjk380 is offline  
July 27th, 2018, 03:36 AM   #3
Junior Member
 
Joined: Apr 2015
From: Riverina NSW Australia

Posts: 19
Thanks: 5

I Ride: 2011 FE 570, Yamaha IT 490
Hi Tourist, thanks for the tip. Ill look at putting a piece of tube in. Ill change the seal and install tne tube.

Last edited by Peter570; July 27th, 2018 at 03:44 AM. Reason: Cant spell
Peter570 is offline  
July 27th, 2018, 03:45 AM   #4
Junior Member
 
Joined: Apr 2015
From: Riverina NSW Australia

Posts: 19
Thanks: 5

I Ride: 2011 FE 570, Yamaha IT 490
How do i add a photo or two?
Peter570 is offline  
July 27th, 2018, 09:09 AM   #5
Member
 
pjk380's Avatar
 
Joined: Sep 2012
From: Yorba Linda, CA

Posts: 30
Thanks: 3

I Ride: 09 FE 450, KTM 380/SmartCarb
In advanced "reply to thread" select "Attachments" icon and upload your photo. Or you can use photobucket or other photo sharing site and use "Insert Image" icon to provide the link. The image below is an "attachment"
Simpson Desert tour-waterpump_mod.jpg
pjk380 is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
desert, simpson, tour



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Set up for the Simpson desert Gav450 New Users 7 October 29th, 2016 12:25 PM
Albania tour walter27 Ride Reports 1 June 12th, 2016 11:46 PM
Looking For OZ Motorcycle Tour duckracer Husaberg 2 January 14th, 2010 10:49 PM
Anyone desert racing the new 570 or 450 in US ?? Gazza Husaberg 0 August 25th, 2009 02:47 PM
Atlantic Coast Dealer tour Jedi Husaberg 23 April 8th, 2005 08:39 AM


Facebook Twitter Google+ RSS Feed