Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Thanks Tree1Thanks
  • 1 Post By Spuddy18
Reply
 
LinkBack Thread Tools Display Modes
June 27th, 2018, 09:16 AM   #1
Junior Member
 
Joined: Jun 2018
From: Northeast England

Posts: 22
Thanks: 9

I Ride:
New berg 650 owner clutch/headlight questions

Hi guys picked up an 02 fs650 and have a few questions to ask. I have adjusted valve clearences changed oil and filter used motul v300 10w40. And gave everything a once over. The clutch needs pulled right back and even when it is the bike still wants to pull. It was also doing this before the oil change btw. I have bled it and asjusted lever adjuster all way in and as soon as i touch lever can see clutch plates starting to move and seperate but still the same needs pulled right in and still tries to go (clutch grab). Is this normal or anything i can do? Also i fitted the standard headlight back on and i have no battery so stator onlybut find dipped beam is ok at idle but if revved goes very dim but the high beam side stays bright all the time when revved. I thought stators the more its revved the brighter the light?

Jason.
roach308 is offline  
 
June 27th, 2018, 12:55 PM   #2
Junior Member
 
Joined: May 2018
From: England

Posts: 18
Thanks: 8

I Ride:
You may find you have the common faukt of the clutch plates wearing onto the basket or hub. This stops them from moving freely and usually means you can't find neutral.
There is a upgrade kit sold by taffy on here that solves that issue. You may find with that, the clutch plates can all move freely and full disengage.
As for the light, yes it should get brighter as you rev? Mine did certainly before I converted it to a 3ph rectifier. Weird how it does it correct on high beam but not low beam. Try another bulb? Or check for any wiring damage on the low beam side causing a resistance?

Sent from my E6533 using Tapatalk
Thanks from roach308
Spuddy18 is offline  
June 27th, 2018, 01:40 PM   #3
Junior Member
 
Joined: Jun 2018
From: Northeast England

Posts: 22
Thanks: 9

I Ride:
Thanks for your reply. I will look into the kit you mentioned. And yeah i was thinking maybe wiring but strange its bright at idle therefore no resistance. Still i will check it by volt dropping at the bulb and further down the wiring
roach308 is offline  
July 1st, 2018, 03:51 AM   #4
Junior Member
 
Joined: May 2018
From: England

Posts: 18
Thanks: 8

I Ride:
Originally Posted by roach308 View Post
Thanks for your reply. I will look into the kit you mentioned. And yeah i was thinking maybe wiring but strange its bright at idle therefore no resistance. Still i will check it by volt dropping at the bulb and further down the wiring
No worries.
If the bulb continues to be a pain, you could look at converting the bike to a 3ph rectifier. I got mine from vehicle wiring products online. Neat little unit and takes 3 phases from the generator to give to u a nice stable upto 200w 12v dc output. I ran that straight to my battery (must have a battery or capacitor as a buffer) and then run my bike and lighting from there.
Plus side is no dim lights at all, as it draws from the battery when the generator isn't producing enough.
Not a very expensive mod either

Sent from my E6533 using Tapatalk
Spuddy18 is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
650, berg, clutch or headlight, owner, questions



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
New 570 owner w/ questions 1lunger Husaberg 3 November 24th, 2013 09:29 PM
New Berg Owner..but many questions WeezerG Husaberg 1 August 9th, 2013 07:56 AM
New Berg Owner With Questions looki Husaberg 2 September 23rd, 2009 11:17 AM
New 650 owner questions 650Montana Husaberg 2 June 17th, 2006 12:39 PM
FE650e Headlight Questions rustie Electrical 13 February 1st, 2005 09:30 PM


Facebook Twitter Google+ RSS Feed