Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Thanks Tree55Thanks
Reply
 
LinkBack Thread Tools Display Modes
September 21st, 2017, 04:06 PM   #31
Senior Member
 
bushmechanic's Avatar
 
Joined: Jun 2007
From: south east WA Australia

Posts: 3,767
Thanks: 1060

I Ride: 2008 700FK, 2002 628FST
Sorry I dont recall suggesting removing the elephants feet

I suggested taking the whole foot assembly out and grinding the rocker arm so that the foot could be repositioned higher up.

With 33 38 you need longer valves anyway because they sit further toward the piston than the smaller ones

I've not done it with the polaris valves but I bet a bazillion crocksits I could do it in a weekend.
Thanks from tourist and paolo6
bushmechanic is offline  
 
September 24th, 2017, 07:00 PM   #32
Senior Member
 
polska's Avatar
 
Joined: Mar 2016
From: Burlington

Posts: 200
Thanks: 44

I Ride: '07Exc 525 & '07 FS 550.Just sold ' 08 Ktm 450 sxf.
Looks like I misunderstood you Bushie, I never heard of elephants feet. Those are round buttons at the end of adjusting screws? So grinding rockers would simply allow me to retract adjustment further out?. I told the shop that was changing the seats and guides that I want valves to be in exactly the same position/depth as originals. I didn't want to have any surprises with the piston contact or increasing the compression ratio/reducing combustion chamber volume.
Attached Thumbnails
Paolo6 a new start-20170418_221329.jpg   Paolo6 a new start-20170418_222411.jpg  
polska is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
paolo6, start



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with start, will start but not run, just for seconds.. Lielie95 Mechanical 11 December 4th, 2016 09:09 AM
how can i start with electric start to my husaberg 650e naturalturk Tech 2 January 3rd, 2010 10:28 AM
Malfunction electric start,OK Startmotor,OK Battery,NO START AWelland Mechanical 5 November 3rd, 2008 01:56 PM
Bike Died No Kick Start Only Bump Start[Broken Valve Spring] TCK! Mechanical 26 May 17th, 2007 10:57 AM
kick start, electric start problem vinman1513 Mechanical 1 March 15th, 2006 01:42 PM


Facebook Twitter Google+ RSS Feed