Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Thanks Tree5Thanks
  • 3 Post By Mudme
  • 1 Post By lvspeed
  • 1 Post By Mudme
Reply
 
LinkBack Thread Tools Display Modes
June 8th, 2017, 02:55 AM   #1
Junior Member
 
Joined: Jun 2017
From: Officer,victoria

Posts: 9
Thanks: 5

I Ride:
New rider to the forum

Hi guys just bought myself a 2000 fe400e first burger I've owned any tips I need to know? I ride mostly up in the high country in Vic

Cheers
Thanks from zen, canolman and paolo6
Mudme is offline  
 
June 8th, 2017, 02:41 PM   #2
Member
 
Joined: Dec 2016
From: Port Moody, BC, Canada

Posts: 74
Thanks: 28

I Ride: Husaberg 400 FE
Breakoutthetools

Hallo Mudme. Welcome and huge points for having your old trailer matching the new Berg so well! Glad to see the hounds are watching you suspiciously. They already feel the bike is part of the family.
Bike looks in remarkable condition. Body work rarely stays that nice, what with frequent endos, bouncing off trees, etc.
Ok, put bike on some kind of stand, with both wheels touching ground. Then pull out the swing arm pivot shaft. It is usually corroded. Polish it with sand paper till spotless, clean with new rag and WD40, coat with waterproof grease (Bel-Ray). Might need new proper axle nuts. Repeat this ordeal with every axle or pivot on the bike. While in there, try to clean and then stuff every external bearing or rubbing surface with that grease.
Pull tank off. Remove petcocks, they are nearly blocked. Service engine. Use new fuel filter. Etc. Spin wheel bearings with your finger. The rear ones might be rough. Chain guides ok? Master link damaged? You get the idea.
You might want to avoid taking liberties with the Husaberg name. I got heck for that once.
Thanks from tourist
lvspeed is offline  
June 10th, 2017, 02:27 AM   #3
Junior Member
 
Joined: Jun 2017
From: Officer,victoria

Posts: 9
Thanks: 5

I Ride:
Serviced it today, new filter and oil, new plug cleaned and re oiled air filter, pet cocks were blocked pulled carby apart and cleaned it, man this thing is a bitch to start cold! Was fine once warm and ran great but very hard to start from cold!
Mudme is offline  
June 10th, 2017, 02:39 AM   #4
Senior Member
 
tourist's Avatar
 
Joined: Nov 2012
From: Iceland

Posts: 2,367
Thanks: 797

I Ride: 1 Berg, 1 Zook
welcome
tourist is offline  
June 10th, 2017, 09:33 AM   #5
zen
Site Admin
 
zen's Avatar
 
Joined: Aug 2013
From: Washington

Posts: 185
Thanks: 238

I Ride: Husa!
Welcome to the Husaberg Forum family!
zen is offline  
June 12th, 2017, 01:01 AM   #6
Junior Member
 
Joined: Jun 2017
From: Officer,victoria

Posts: 9
Thanks: 5

I Ride:
So after completely pulling the carby apart and giving it a good clean now all I do from cold is turn the idle screw 3 turns and it starts straight away, fairly happy with that!
Thanks from tourist
Mudme is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
forum, rider



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
New to the forum ldimauro06 New Users 13 May 30th, 2015 08:02 PM
New to this forum SunnyRSA Husaberg 1 April 30th, 2011 08:01 PM
NEW HUSABERG RIDER- EX KTM,GAS GAS RIDER arreola1 Husaberg 1 January 22nd, 2010 12:38 PM
New to the forum bikebarnbeckman Husaberg 11 June 27th, 2005 10:27 PM


Facebook Twitter Google+ RSS Feed