Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Thanks Tree2Thanks
  • 1 Post By phillboy
  • 1 Post By Smash101
Reply
 
LinkBack Thread Tools Display Modes
April 2nd, 2017, 11:56 AM   #1
Junior Member
 
phillboy's Avatar
 
Joined: Apr 2017
From: Exeter

Posts: 14
Thanks: 1

I Ride:
Fe 350 won't start

Help needed please while trail riding today I feel and broke my front light on my 2013 fe 350 but from that point on the bike won't start nothing at all at the switch ? I tried the fuses and all ok so a little stuck any ideas ????


Sent from my iPad using Tapatalk
phillboy is offline  
 
April 2nd, 2017, 02:09 PM   #2
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,035
Thanks: 327

I Ride:
sorry....you'll just have to trace everything through. do you have a key or is it key-less?

you need power to the leccy button and you want to get a signal when you press the starter button. that's the start point anyway.

Taffy
Taffy is online now  
April 2nd, 2017, 04:53 PM   #3
Senior Member
 
FE350's Avatar
 
Joined: Apr 2014
From: Chilliwack, BC, Canada

Posts: 653
Thanks: 239

I Ride: 2014 FE350, Beautiful Blonde
Will it turn over or is everything dead?
FE350 is offline  
April 2nd, 2017, 10:49 PM   #4
Junior Member
 
phillboy's Avatar
 
Joined: Apr 2017
From: Exeter

Posts: 14
Thanks: 1

I Ride:
No nothing at all as if there's no power, I'm taking a proper look later today as Had minimal tools with me yesterday


Sent from my iPhone using Tapatalk
phillboy is offline  
April 2nd, 2017, 11:19 PM   #5
Senior Member
 
FE350's Avatar
 
Joined: Apr 2014
From: Chilliwack, BC, Canada

Posts: 653
Thanks: 239

I Ride: 2014 FE350, Beautiful Blonde
Check both ground and power from your battery and the junction to your fuse panel. I am also thinking that you might want to look at your harness at impact point on your front plate as you might find the plate cut the harness?
FE350 is offline  
April 3rd, 2017, 01:29 AM   #6
Senior Member
 
Joined: Mar 2015
From: Melbourne, Australia

Posts: 188
Thanks: 63

I Ride: 2010 FX 450
It will be the main fuse, you must of created a short when you broke the light. The main fuse is not located with the rest of the fuses. Correct me if I'm wrong but I believe it's under the battery.


Sent from my iPad using Tapatalk
Smash101 is offline  
April 3rd, 2017, 01:30 AM   #7
Junior Member
 
phillboy's Avatar
 
Joined: Apr 2017
From: Exeter

Posts: 14
Thanks: 1

I Ride:
Originally Posted by Smash101 View Post
It will be the main fuse, you must of created a short when you broke the light. The main fuse is not located with the rest of the fuses. Correct me if I'm wrong but I believe it's under the battery.


Sent from my iPad using Tapatalk


Checked that there all good


Sent from my iPhone using Tapatalk
phillboy is offline  
April 3rd, 2017, 06:27 AM   #8
Junior Member
 
phillboy's Avatar
 
Joined: Apr 2017
From: Exeter

Posts: 14
Thanks: 1

I Ride:
Originally Posted by phillboy View Post
Checked that there all good


Sent from my iPhone using Tapatalk


I stand corrected it was main fuse looked good swapped it with spare and that was broke to everyday a learning day thanks for your help just need to source a new head light


Sent from my iPhone using Tapatalk
Thanks from Smash101
phillboy is offline  
April 3rd, 2017, 04:31 PM   #9
Senior Member
 
Joined: Mar 2015
From: Melbourne, Australia

Posts: 188
Thanks: 63

I Ride: 2010 FX 450
Just carefully check for shorts as the second fuse may have been ok when installed and was buggered again after hitting the starter. Have a look around the starter for damaged wires, normally the smaller fuses will blow before the main fuse.


Sent from my iPad using Tapatalk
Thanks from phillboy
Smash101 is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
350, start



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i start with electric start to my husaberg 650e naturalturk Tech 2 January 3rd, 2010 10:28 AM
Malfunction electric start,OK Startmotor,OK Battery,NO START AWelland Mechanical 5 November 3rd, 2008 01:56 PM
Bike Died No Kick Start Only Bump Start[Broken Valve Spring] TCK! Mechanical 26 May 17th, 2007 10:57 AM
kick start, electric start problem vinman1513 Mechanical 1 March 15th, 2006 01:42 PM
kick start to duel start?? cookeye Mechanical 12 January 7th, 2005 07:28 AM


Facebook Twitter Google+ RSS Feed