Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Reply
 
LinkBack Thread Tools Display Modes
June 13th, 2012, 01:41 AM   #1
Junior Member
 
Joined: Jun 2012
From:

Posts: 8
Thanks: 0

I Ride:
speedo stopped working all of a sudden

does anyone know of any common problems with the original speedo on a 2005 fe 550, one ride it worked then next it didnt even turn on, it never got a large amount of water on it so i got no idea what else it might be
trent_181 is offline  
 
June 13th, 2012, 11:08 PM   #2
Member
 
Joined: Feb 2012
From: Townsville Australia

Posts: 83
Thanks: 2

I Ride: 2008 FE650
Re: speedo stopped working all of a sudden

Sounds like a loose connection? I pulled all my plugs on the bike apart when I got it and filled it with CRC so corrosion and moisture wouldn't be a problem. I'd do that and you might be lucky enough to find the problem
08FE650 is offline  
June 14th, 2012, 03:17 AM   #3
Junior Member
 
Joined: Jun 2012
From:

Posts: 8
Thanks: 0

I Ride:
Re: speedo stopped working all of a sudden

righto thanks mate ill give it a try
trent_181 is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
speedo, stopped, sudden, working



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
fe570 themo fan stopped working buffalo450 Cooling Systems 17 June 5th, 2015 08:56 AM
Speedo Working Oddly HeyJohnnyPark Electrical 0 August 3rd, 2009 02:39 PM
How to test a speedo is working? rmgcook Electrical 8 June 25th, 2008 09:44 PM
sudden rattling noise oyk Mechanical 12 June 29th, 2007 07:16 PM
FE400E Just stopped! Nugs Electrical 25 July 20th, 2004 12:11 AM


Facebook Twitter Google+ RSS Feed