Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Reply
 
LinkBack Thread Tools Display Modes
October 6th, 2013, 01:20 AM   #81
Junior Member
 
Joined: Feb 2012
From: Sweden

Posts: 4
Thanks: 0

I Ride: FE570
Re: Buying a new FE570? Known issues, problems & common mods

Is it inside the hose? A part of the quick connector? I canīt see anything on the hose from the quick connector to the throttle body....
linnell is offline  
 
October 6th, 2013, 08:26 AM   #82
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 1,061
Thanks: 488

I Ride: Two FE570 -12
Re: Buying a new FE570? Known issues, problems & common mods

It's in the hose. You need to remove the hose clamp to pull the hose of the injector assembly. When you put it together you need another hose clamp as the OEM can't be used again.
jon andersson is offline  
October 7th, 2013, 06:18 AM   #83
Junior Member
 
Joined: Feb 2012
From: Sweden

Posts: 4
Thanks: 0

I Ride: FE570
Re: Buying a new FE570? Known issues, problems & common mods

There is no inline filter between the quick connect and throttle body on my Berg... strange. Maybe the pump itself is my problem....
linnell is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
buying, common, fe570, issues, mods, problems



Search tags for this page
Click on a term to search for related topics.
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 FE570 starting issues and fix Haskell Mechanical 2 January 13th, 2011 01:54 AM
2010 FE570, Standard exhaust mods? nick790 Exhausts 1 November 21st, 2010 06:22 AM
'09 FE570 Issues??? duckracer Husaberg 20 August 30th, 2010 12:19 AM
1 Year on, any problems with FE570's yet ?? eyspy Husaberg 4 October 28th, 2009 08:31 AM
2009 FE570 Mods? ozbika22 Husaberg 3 January 2nd, 2009 11:44 AM


Facebook Twitter Google+ RSS Feed