Husaberg
Go Back   Husaberg Forum > Husaberg Forum > Husaberg

Husaberg Husaberg Forum - Husaberg Motorcycle Forum


Reply
 
LinkBack Thread Tools Display Modes
September 19th, 2011, 11:50 AM   #11
Senior Member
 
Joined: Dec 2010
From: Yorkshire UK

Posts: 271
Thanks: 4

I Ride:
Re: 2010 570 hard to start initially

I NEVER pull out the idle button to start from cold 'cos I found it used to race the engine. I just turn up the idle 3-4 clicks, stab the button momentarily to prime the injector then it'll start after a couple of turns. Using this metod I've never had any starting issues, excluding the fuel pump fiasco of course but that's another story Lol!
pegscraper is offline  
 
September 19th, 2011, 06:02 PM   #12
Junior Member
 
Joined: Sep 2011
From: Portland, Oregon

Posts: 25
Thanks: 0

I Ride:
Re: 2010 570 hard to start initially

Thanks guys; I'll give these tricks a try and see if I notice any difference...
Dual Rider is offline  
October 4th, 2011, 07:44 AM   #13
Junior Member
 
Joined: Sep 2011
From:

Posts: 22
Thanks: 0

I Ride:
Re: 2010 570 hard to start initially

I have the exact same problem on my brand new 2011 570s. I have it in my truck to take back to the dealer this afternoon, this is unacceptable!

I was running the bike with out the little end cap in the pipe, and I put it back in and it seems to fire a little better, but not like it should.

I have tried all listed except for the filter, I will clean it very good and see what the dealer has to say.

Thanks everyone. Be Blessed, Eric.
BIG-E is offline  
October 4th, 2011, 09:18 AM   #14
Senior Member
 
Joined: Sep 2009
From: Arroyo Grande, California

Posts: 196
Thanks: 0

I Ride:
Re: 2010 570 hard to start initially

Re-mapping the ECU will make all the difference on the 2011. Mine had the stock map (programmed for EPA
regulations) and when I had it re-mapped with the closed course European map, starting issues all went away.
Barshoe is offline  
October 6th, 2011, 08:48 AM   #15
Junior Member
 
Joined: Sep 2011
From:

Posts: 22
Thanks: 0

I Ride:
Re: 2010 570 hard to start initially

Belive it or not, when I dropped my bike off at the dearlership, I was telling him how hard it was to start and he turned the key on and hit the starterfor a milli-second, and it fired right up!!

I did re-install the end piece on the rear of the pipe, but dang it!

I am having the Europe closed course setting installed. And I had them remove all the smog stuff.

Thanks everyone for all your help!
BIG-E is offline  
October 6th, 2011, 06:35 PM   #16
Senior Member
 
Joined: Sep 2009
From: Arroyo Grande, California

Posts: 196
Thanks: 0

I Ride:
Re: 2010 570 hard to start initially

That a boy! You'll be glad you did!
Barshoe is offline  
Reply

  Husaberg Forum > Husaberg Forum > Husaberg

Tags
2010, 570, hard, initially, start



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard to start....what else is new drdfblackm Fuel 4 April 20th, 2007 09:45 PM
hard cold start sometimes hard hot start deadeyedick Fuel 5 August 27th, 2006 05:02 PM
Hard to re start hot 600 Curly Fuel 6 October 25th, 2005 11:33 AM
Hard to start... SM_Master Mechanical 10 October 5th, 2005 04:08 AM
Hard/No Start fish Mechanical 10 July 19th, 2005 07:53 AM


Facebook Twitter Google+ RSS Feed