Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Fuel

Fuel Fuel Delivery


Reply
 
LinkBack Thread Tools Display Modes
June 5th, 2006, 09:11 AM   #1
Junior Member
 
daniel's Avatar
 
Joined: Nov 2005
From:

Posts: 4
Thanks: 0

I Ride:
Problems with firing the engine

Hi,
I have a husaberg 600 fc 99, after longer rides there are problems with firing the engine and the spark is black. what is more when I riding down on a gear but without adding power the exhaust is shooting.
There is a screw in a which is responsible for making a mixture of fuel an air, the question is how much this screw should be open(I was told that one and half cycle)?
Daniel. Poland
daniel is offline  
 
June 5th, 2006, 11:27 AM   #2
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,346
Thanks: 393

I Ride: Husaberg FE501e 2003
Re: Problems with firing the engine

hello daniel

it's known that the dell orto carb wears out. the more it wears the richer it runs. bikes need to be quite lean to restart and so you have the answer to your problem i think!

try and renew the emulsion tube and needle.

also do all the usual things such as check the float is even, it's height, blow out all holes.

you can check your atomiser/emulsion tube visually by holding it to the light in the garage. it will look oval if worn. your bike is a '99 so it may be time!

good luck

Taffy
Taffy is offline  
June 7th, 2006, 02:43 PM   #3
Senior Member
 
Joined: Jan 2004
From: lemont,illinois

Posts: 197
Thanks: 4

I Ride:
Re: Problems with firing the engine

hey Taffy,I was surprised to hear I need to be leaner for e-start,just wondering what you might recomend for a starting point,My98fe 600 runs pretty well except wont start on the button,went through the whole carb and changed the needlek51,dr272needle jet,42 pilot jet,45 start jet and a 180 mainjet.it usually starts first kick hot,third kick cold.I had a 38 pilot in for awhile couldnt notice much difference except seemed to run a little hot.
schultzy is offline  
June 7th, 2006, 09:45 PM   #4
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,346
Thanks: 393

I Ride: Husaberg FE501e 2003
Re: Problems with firing the engine

again you have the answer in front of you! the 38 pilot jet.

it's a fact of life that a rich bike has a combustion temp of 500d whilst the correct temp is 800d and lean is 1300d. so you can expect a slight rise in temp. so what?

regards

Taffy
Taffy is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Fuel

Tags
engine, firing, problems



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
650 engine miss firing. craig p Husaberg 3 January 11th, 2013 03:15 PM
Engine part problems Twiztedtechs Mechanical 3 September 19th, 2010 08:17 PM
2001 and 2002 FE400e engine problems longshanks Husaberg 2 March 18th, 2007 07:02 AM
2002 Berg engine problems Semtexsam Mechanical 6 November 7th, 2005 10:25 PM
Problems with my Engine!! wiegoldj Husaberg 2 July 20th, 2005 05:36 AM


Facebook Twitter Google+ RSS Feed