Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Fuel

Fuel Fuel Delivery


Thanks Tree1Thanks
  • 1 Post By 1Trak Mind
Reply
 
LinkBack Thread Tools Display Modes
August 5th, 2019, 08:45 AM   #1
Member
 
Joined: Jan 2011
From: va.usa

Posts: 48
Thanks: 1

I Ride:
No start after tip over ?

Hey All,
Had a tip over then bike would not start. Got it home and replaced pump with Cacycle pump but still no or very low fuel pressure .
I am showing about 1 bar or 14 psi while cranking and then pressure falls to zero. It appears to be pressure regulator bleeding down not holding pressure .
Anyone seen a similar issue ? Any way to isolate regulator for diagnosing ?
Thanks
1Trak Mind is offline  
 
August 6th, 2019, 07:37 AM   #2
Moderator
 
ned37's Avatar
 
Joined: Dec 2004
From: back in cottonwood, az

Posts: 2,358
Thanks: 205

I Ride: '08 HUSKY te610
just a wild guess since i have no idea which model you're talking about, but have you checked the TIP OVER SWITCH?
ned37 is offline  
August 6th, 2019, 08:04 AM   #3
Member
 
Joined: Jun 2019
From: Alameda, CA

Posts: 99
Thanks: 14

I Ride: FE570,FS570,450/520XCF SM, SV1000, NC700
From other posts he made I suspect it's a 2010 FE570.
Junkie is offline  
August 7th, 2019, 03:36 AM   #4
Member
 
Joined: Jan 2011
From: va.usa

Posts: 48
Thanks: 1

I Ride:
Oh yes, might help if we knew what we were talking about.
It is a 2010 fe 570.
Can you tell me where the tip over switch is ? I have no idea ,How do you check it ?
Thanks

Last edited by 1Trak Mind; August 7th, 2019 at 03:43 AM.
1Trak Mind is offline  
August 7th, 2019, 07:28 AM   #5
Moderator
 
ned37's Avatar
 
Joined: Dec 2004
From: back in cottonwood, az

Posts: 2,358
Thanks: 205

I Ride: '08 HUSKY te610
google is your friend
ned37 is offline  
August 8th, 2019, 04:04 AM   #6
Member
 
Joined: Jan 2011
From: va.usa

Posts: 48
Thanks: 1

I Ride:
Gee thanks
1Trak Mind is offline  
August 8th, 2019, 08:28 PM   #7
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 991
Thanks: 243

I Ride: 8 Berg’s 2005-2011 2 Husky’s 1986&7 2009 Buell & 2006 Ducati
Looked up 570 Husaberg Rollover sensor on the internet. This is what came up on Husaberg.org May 15th 2013 from transporter should be helpful.
Rainerio is offline  
August 12th, 2019, 06:09 AM   #8
Member
 
Joined: Jan 2011
From: va.usa

Posts: 48
Thanks: 1

I Ride:
I pulled the fuel pump assy w regulator and lines then submerged the pump in container of fuel.
Then powered up the pump w 12v source , fuel filter had ruptured causing lack of fuel pressure.
This was replaced less than a year ago w factory part.
Thanks from jon andersson
1Trak Mind is offline  
August 15th, 2019, 12:18 AM   #9
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 1,082
Thanks: 503

I Ride: 3x FE570
Good that you found the problem!

FYI the rollover sensor is located under the battery compartment close to the shock.
jon andersson is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Fuel

Tags
start, tip



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with start, will start but not run, just for seconds.. Lielie95 Mechanical 11 December 4th, 2016 10:09 AM
how can i start with electric start to my husaberg 650e naturalturk Tech 2 January 3rd, 2010 11:28 AM
Malfunction electric start,OK Startmotor,OK Battery,NO START AWelland Mechanical 5 November 3rd, 2008 02:56 PM
Bike Died No Kick Start Only Bump Start[Broken Valve Spring] TCK! Mechanical 26 May 17th, 2007 11:57 AM
kick start, electric start problem vinman1513 Mechanical 1 March 15th, 2006 02:42 PM


Facebook Twitter Google+ RSS Feed