Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Fuel

Fuel Fuel Delivery


Thanks Tree3Thanks
  • 1 Post By Rainerio
  • 2 Post By Smash101
Reply
 
LinkBack Thread Tools Display Modes
August 6th, 2017, 08:53 PM   #1
Junior Member
 
Joined: Sep 2016
From: Brooklyn, NY

Posts: 11
Thanks: 6

I Ride: 2010 Husaberg FE390 - dirt only
Possible fuel pump problem. Need help

I was wondering if owners in the know can confirm and/or recommend what steps/actions I should do.

I went on the ride yesterday. It wasn't too hot out and I was riding maybe for about 1.5 hours. A few time I felt like the bike cut out temporarily a few times at close to idle speed when I was riding slow in 1st gear. At first I didn't pay too much attention. But unfortunately it then shut down and wouldn't restart. Battery is fine and strong and cranking really good. But it feels as though fuel pump is not pumping any fuel and no fuel is going into throttle body.

Bike is 2010 FE390 with 325 miles and like 26 hours at most.

From reading thru the forum it sounds as fuel pump but I am not certain.

If anyone have recommendations or suggestions , please chime in
Falcolion is offline  
 
August 6th, 2017, 09:44 PM   #2
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 809
Thanks: 178

I Ride: 7 Husabergs two FE570S,FS570 FE390/450,07 FE650,05 FE550,2 Husqvarna's 86 WR400,87 510,09 Buell
Pour a really small amount of fuel into throttle body and try to start it. If it runs then it's fuel related. More then likely it's the fuel pump. But it can be 1 of 2 or 3 fuel filters or fuel regulator. You should have an extra fuel pump anyway. When my bike took the big S no warning just a pop then nothing. Fuel filters 1 in tank , 1 at injector and 1 where you disconnect fuel line from the tank. Not a bad idea to check/replace as needed them all especially if your replacing the fuel pump. Good luck
Thanks from jon andersson
Rainerio is offline  
August 7th, 2017, 06:39 PM   #3
Junior Member
 
Joined: Sep 2016
From: Brooklyn, NY

Posts: 11
Thanks: 6

I Ride: 2010 Husaberg FE390 - dirt only
Thanks
Falcolion is offline  
August 16th, 2017, 12:25 AM   #4
Senior Member
 
Joined: Mar 2015
From: Melbourne, Australia

Posts: 187
Thanks: 62

I Ride: 2010 FX 450
Check the battery connections are tight, same thing happened to my sons 2013 Fe450 and my 2010 FX450. They randomly cut out, some times stalled and some times keep running, they both cranked normally. Both had loose battery connections and no neither one of us fitted the battery


Sent from my iPad using Tapatalk
Thanks from tourist and Rainerio
Smash101 is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Fuel

Tags
fuel, problem, pump



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Pump problem or something else?? aaronc70 Fuel 54 June 16th, 2017 09:58 AM
possible fuel pump problem? georgemilchick Husaberg 17 October 17th, 2015 06:14 PM
FE 570 '09 - dead bike, possible fuel pump problem? Pole Fuel 3 May 13th, 2013 11:57 AM
fuel pump problem lucas71 Fuel 1 January 26th, 2012 10:33 AM
Another fuel pump problem?? 2012 FE570 tezza527 Fuel 14 December 6th, 2011 05:35 AM


Facebook Twitter Google+ RSS Feed