Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Fuel

Fuel Fuel Delivery


Thanks Tree3Thanks
  • 3 Post By RogerB39
Reply
 
LinkBack Thread Tools Display Modes
August 24th, 2016, 10:50 AM   #1
Junior Member
 
Joined: Aug 2016
From: Grand Rapids

Posts: 4
Thanks: 0

I Ride:
450fx cutting out

I need help. I have a 450fx. Cuts out when coming out of corners and hitting throttle hard from idle. I have put new- fuel pump, fuel filter, new plug, new plug cap, air filter is new, new battery!?!? Still will die on me!?

Last edited by Jester4130; August 24th, 2016 at 12:02 PM. Reason: More details
Jester4130 is offline  
 
August 24th, 2016, 12:50 PM   #2
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 809
Thanks: 178

I Ride: 7 Husabergs two FE570S,FS570 FE390/450,07 FE650,05 FE550,2 Husqvarna's 86 WR400,87 510,09 Buell
This just a guess but check your throttle position sensor if it's a 70d motor.
Rainerio is offline  
August 24th, 2016, 12:53 PM   #3
Junior Member
 
Joined: Aug 2016
From: Grand Rapids

Posts: 4
Thanks: 0

I Ride:
It is the 70d. Motor. I haven't messed with that. I don't know enough about it just yet.
Jester4130 is offline  
August 24th, 2016, 01:00 PM   #4
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 809
Thanks: 178

I Ride: 7 Husabergs two FE570S,FS570 FE390/450,07 FE650,05 FE550,2 Husqvarna's 86 WR400,87 510,09 Buell
I don't know much either. You check resistance with a ohms meter. Look on the site for numbers it set it at or check if it's in tolerance.
Rainerio is offline  
August 24th, 2016, 01:41 PM   #5
Junior Member
 
Joined: Aug 2016
From: Grand Rapids

Posts: 4
Thanks: 0

I Ride:
I have been putting parts on hoping that fixes it. Stumped!!!!
Jester4130 is offline  
August 25th, 2016, 09:36 AM   #6
Member
 
RogerB39's Avatar
 
Joined: Oct 2011
From: Pacific Northwest

Posts: 54
Thanks: 8

I Ride: FX450 - sold, '08 KTM 690SMR, '12 KTM250SXF (SOLD) 2016 Husky FC250 new race bike!
Hey Jester
I've been going through a very similar issue, that I think (I hope) I have finally solved.
Is it worse when the bike is warmed up?
Long story short, I think I accidentally found the culprit. Check the fuel line routing just before the injector/throttle body.
I happened to find mine was kinked, badly, and I'm guessing as my bike warmed up, the hose got softer and pinched/restricted fuel flow.
I usually leave my shrouds on when removing the tank, so I never saw the line till I happen to take the left side shroud off and there it was, kinked like crappy garden hose.
It would explain why, in my case, the bike would work great for a couple laps (I race supermoto) then start acting up...(getting worse when the bike warmed up and the hose got more compliant?).
I've installed a hard line, 90deg elbow, just off the injector with hopes this fixes it. (hose no longer is bent over to reach the injector)
For the record, I've been chasing this thing for a while.
I have replaced...
Tip over switch, Spark plug, Cap, Coil/Plug wire, Fuel pump & filters, even the pick up coil at the flywheel.
It's been on a factory diagnostics computer and showed no faults at all...totally stumped us. I've not a chance to run the bike hard yet to see if I've finally fixed it. I'll keep you posted!
Thanks from jon andersson, cambo and Rainerio

Last edited by RogerB39; August 25th, 2016 at 04:07 PM.
RogerB39 is offline  
August 26th, 2016, 09:30 AM   #7
Junior Member
 
Joined: Aug 2016
From: Grand Rapids

Posts: 4
Thanks: 0

I Ride:
It doesn't happen only when warm. It happens right after I started the bike. If I throttle hard it will quit!?!? It does it out of corners. I am so frustrated. Also, scared to ride hard.
Jester4130 is offline  
September 2nd, 2016, 11:12 AM   #8
Member
 
RogerB39's Avatar
 
Joined: Oct 2011
From: Pacific Northwest

Posts: 54
Thanks: 8

I Ride: FX450 - sold, '08 KTM 690SMR, '12 KTM250SXF (SOLD) 2016 Husky FC250 new race bike!
Have you checked/cleaned the injector?
Lots of stuff on youtube on how to do it. Yes, I also did this chasing my cutting-out issue.
My FX450 did'nt have the tiny inline filters that some of the other Berg's have. Have you checked to see if you have them, and if so, are they dirty?
The problem you're describing sure sounds like fuel starvation/delivery.
Can you roll the throttle slow and still reach full throttle? Does it only cut out when opening the throttle aggressively?
The TPS may be too lean as well? Again, how to check and set is on Youtube
(look for the KTM tutorials) A voltage meter and come jumper wires are all you need.
RogerB39 is offline  
September 11th, 2016, 08:09 PM   #9
Member
 
RogerB39's Avatar
 
Joined: Oct 2011
From: Pacific Northwest

Posts: 54
Thanks: 8

I Ride: FX450 - sold, '08 KTM 690SMR, '12 KTM250SXF (SOLD) 2016 Husky FC250 new race bike!
Well, had a go with the fuel line fix, and it still isn't fixed. Even put a one piece fuel line from the tank to the throttle body/injector. Still cuts out on WFO throttle. It's intermittent, which is maddening. Bike refires on its own, after a second or two, too. This weekend was bad as I was lined up front row in my first heat race, and it died as I was shifting into third, WFO, with the hole-shot! All I could do was pray like hell no one corn-holes me...luckily everyone behind me for around safely.
A couple more things I'm going to try...I'll update with more news when I have it.
RogerB39 is offline  
September 11th, 2016, 11:27 PM   #10
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 883
Thanks: 344

I Ride: Two FE570 -12
If you know another 70deg owner try to switch ECUs and see if that helps.
jon andersson is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Fuel

Tags
450fx, cutting



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 570 cutting out chris426f Fuel 12 September 18th, 2016 07:06 PM
2011 FE 390 cutting out mattpawsey Electrical 4 October 28th, 2015 05:32 PM
FE 400 cutting out when hot. xbakerbob Husaberg 6 June 3rd, 2012 02:59 AM
Cutting out just a bit? gilgamesh Fuel 33 May 19th, 2007 10:45 AM
501 cutting out after 5min , help craigjdi Electrical 3 July 14th, 2005 09:13 AM


Facebook Twitter Google+ RSS Feed