Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Fuel

Fuel Fuel Delivery


Reply
 
LinkBack Thread Tools Display Modes
June 28th, 2012, 10:16 AM   #1
Junior Member
 
Joined: Nov 2011
From: Leicestershire

Posts: 13
Thanks: 0

I Ride:
FE390 needs throttle to start

Fe390 2010 bike which I bought at 12 months old with 50 hours on it.
Ever since I've had it the bike fires up straight away when cold using the cold start knob and no throttle but when warm it turns over and over without firing unless I give it a touch of throttle. This has always concerned me but never let me down for the 40 hours I've used it but last week a riding buddy's 2011 fe570 fired on the button hot or cold so something isn't right with it.
Just prior to me buying the bike the original owner had broken down with a blocked injector which the dealer had sorted.
I don't really want to start messing with anything and risk introducing dirt into the system if it's not needed.
Is this a known issue or is there a logical process to help solve it?

I have spent a couple of hours searching the forum but can't find anything similar to my issues.

Thanks in advance

Tony
Tonibe63 is offline  
 
June 28th, 2012, 12:43 PM   #2
Member
 
Joined: Nov 2009
From: Wicklow, Ireland

Posts: 62
Thanks: 0

I Ride:
Re: FE390 needs throttle to start

Try adjusting the tick over worked for me
Mxdave is offline  
June 29th, 2012, 04:12 AM   #3
Senior Member
 
Joined: Oct 2009
From: Galston Australia

Posts: 995
Thanks: 10

I Ride:
Re: FE390 needs throttle to start

Originally Posted by Mxdave
Try adjusting the tick over worked for me
What is the "tick over"?
Davo is offline  
June 29th, 2012, 04:42 AM   #4
Senior Member
 
Joined: Oct 2009
From: Galston Australia

Posts: 995
Thanks: 10

I Ride:
Re: FE390 needs throttle to start

One thing to remember is the Fuel Injection in the Husaberg does not use an Idle up Solenoid like every late model Fuel Injected car.
When you start a Fuel Injected car, the Idle up Solenoid does the equivalent of opening the throttle just the correct amount based on the engine coolant temperature and the temperature of the day and whatever else the space heads in the R&D department can think of.
Davo is offline  
June 29th, 2012, 04:57 AM   #5
Member
 
Joined: Nov 2009
From: Wicklow, Ireland

Posts: 62
Thanks: 0

I Ride:
Re: FE390 needs throttle to start

Originally Posted by Davo
Originally Posted by Mxdave
Try adjusting the tick over worked for me
What is the "tick over"?
The Idle
Mxdave is offline  
September 2nd, 2012, 08:03 AM   #6
Junior Member
 
Joined: Sep 2012
From: Greece

Posts: 19
Thanks: 3

I Ride: FE390
Re: FE390 needs throttle to start

i have a 10' fe390...same situation with tonibe63 ''... the bike fires up straight away cold and no throttle but when warm it turns over and over without firing unless I give it a touch of throttle''
toulioss is offline  
September 2nd, 2012, 10:06 AM   #7
Senior Member
 
Joined: Oct 2011
From: Holland

Posts: 160
Thanks: 4

I Ride: FE 390 2010
Re: FE390 needs throttle to start

Same here on my 390. But the 570 is really a pig to start when hot on an MX track. I drove a factory maintained 570, so maintenance shouldn't have been the problem. Liked my 390 better
Noppy is offline  
September 3rd, 2012, 12:39 PM   #8
Member
 
Joined: May 2011
From: Uk

Posts: 89
Thanks: 0

I Ride:
Re: FE390 needs throttle to start

The idle/tick over can be adjusted by turning the choke (cold start) knob under the petrol tank on the left. When you pull choke out you can then rotate it to increase and decrease tick over level.
kipper is offline  
September 3rd, 2012, 01:34 PM   #9
Junior Member
 
Joined: Nov 2011
From: Leicestershire

Posts: 13
Thanks: 0

I Ride:
Re: FE390 needs throttle to start

Originally Posted by kipper
The idle/tick over can be adjusted by turning the choke (cold start) knob under the petrol tank on the left. When you pull choke out you can then rotate it to increase and decrease tick over level.
Tried it but made no difference to my starting problem
Tonibe63 is offline  
October 30th, 2012, 01:37 AM   #10
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 999
Thanks: 440

I Ride: Two FE570 -12
Re: FE390 needs throttle to start

I had a FE390 -10 and when warm I always had to crack the throttle to get it started. I talked to my dealer when I had sold it and bought my 570 and he told me its because of the original ignition mapping.
See it will help if you can get a dealer install a better mapping, you can benefit from that anyway.
jon andersson is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Fuel

Tags
fe390, start, throttle



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
`10 FE390 spluttering at around 1/4 throttle Wallander Husaberg 4 January 13th, 2014 09:57 AM
2010 FE390 Won't Start pmdparts Mechanical 4 August 19th, 2013 03:42 PM
FE390 Intermittent No Start JohnnyQuest Electrical 17 November 15th, 2011 01:34 AM
Malfunction electric start,OK Startmotor,OK Battery,NO START AWelland Mechanical 5 November 3rd, 2008 01:56 PM
Bike Died No Kick Start Only Bump Start[Broken Valve Spring] TCK! Mechanical 26 May 17th, 2007 10:57 AM


Facebook Twitter Google+ RSS Feed