Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Fuel

Fuel Fuel Delivery


Reply
 
LinkBack Thread Tools Display Modes
May 17th, 2012, 11:33 AM   #1
Junior Member
 
Joined: Jun 2011
From: Peru

Posts: 3
Thanks: 0

I Ride:
FS 570 Idle Issue

Gurus, I have a new 2009 FS 570 here in Lima Peru. I purchased this from run out stock and it now has 45 hours and 2000km's. Last week while riding home I pulled up at a set of traffic lights and it stalled which was odd. The bike since then has developed a very erratic idle issue that isn't consistent or predictable. The best I can do at the moment is have it idling EXTREMELY high however even this won't stop it stalling when pulling the clutch in coming up to a set of lights however not all the time. I've done all the simple things like change the fuel, filters etc....any help would be appreciated as the tech support in this part of the world is very questionable
gohard007 is offline  
 
May 18th, 2012, 01:32 AM   #2
Senior Member
 
Joined: Jun 2011
From: Finland

Posts: 351
Thanks: 20

I Ride:
Re: FS 570 Idle Issue

Is it very hot in there? Is it stock bike with stock silencer? Is the mapping stock or competition / de-restricted map installed?

Have you tried to increase the idle by turning the throttle screw counterclockwise on the left side of the throttle body?

Could also be dirty injector / fuel pump issue but you need to check the fuel pressure first or take the injector out to verify that. My bike actually did once or twice that same thing. I idled at the lights and gave little rev and then it suddendly cutted off. But the motor only had 2-3h of running that time, and after that it has been fine.

Check your battery terminal connections too. Mine was loose and same with a friend of mine.
maKe is offline  
May 19th, 2012, 10:40 AM   #3
Junior Member
 
Joined: Jun 2011
From: Peru

Posts: 3
Thanks: 0

I Ride:
Re: FS 570 Idle Issue

The mapping is stock and it has an Akrapovic silencer. Other than that its stock and only three months out of the showroom from new although its an 09 model

The only way I can get it to idle is to turn the throttle screw and get it idling VERY high however as I mentioned even this doesn't work all the time when pulling the clutch in coming up to a set of lights. Yesterday it seemed to do something different also when it was hot at the lights, it would idle high (as I have idle screw adjusted way to much) then it would just slowly idle down and stall? It was just like it was running out of fuel however it would start straight back up and it defiantly has no power issues off idle.

Battery terminals are OK, and I'll pull the injector and check the fuel pressure.

Thanks
gohard007 is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Fuel

Tags
570, idle, issue



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
'10 FE 390 Idle Issue wetsiderider Fuel 0 December 13th, 2012 07:41 PM
95 FE 501 no idle Husadabbler Fuel 3 June 9th, 2010 09:31 AM
09 idle PJ Fuel 2 December 25th, 2008 04:50 PM
Idle only, no run! Dust_Buster Husaberg 2 January 20th, 2005 09:25 PM
Idle When Hot lesmoto Mechanical 8 May 27th, 2004 12:23 PM


Facebook Twitter Google+ RSS Feed