Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Fuel

Fuel Fuel Delivery


Reply
 
LinkBack Thread Tools Display Modes
December 13th, 2011, 07:07 AM   #1
Senior Member
 
Joined: Sep 2009
From: Arroyo Grande, California

Posts: 196
Thanks: 0

I Ride:
We are not alone.....FI issues.

KTM is really getting it's ass kicked on the other websites. Tons of bad fuel pumps and injector issues....

http://beta.thumpertalk.com/topic/89796 ... ssue-2012/
Barshoe is offline  
 
December 14th, 2011, 09:57 PM   #2
Member
 
Joined: Dec 2009
From: Colorado

Posts: 83
Thanks: 2

I Ride:
Re: We are not alone.....FI issues.

I suppose they're using the same crappy Chinese fuel pump.
Busa10 is offline  
December 16th, 2011, 12:01 PM   #3
Moderator
 
Joined: Oct 2002
From: Sunland, CA

Posts: 3,117
Thanks: 19

I Ride:
Re: We are not alone.....FI issues.

The japanese brands have also had their issues...................lots of them, they just don't get talked about by the magazines.

Suzuki had a terrible time with thermal run a way conditions on their pumps early on, japanese pumps, not hech en chino pumps.

IMHO one of the best things you can do is purchase one of the profill drop in filters for your filler neck on your fuel tank to help keep out the dirt.

Dale
DaleEO is offline  
December 16th, 2011, 01:53 PM   #4
Senior Member
 
Joined: Dec 2010
From: Yorkshire UK

Posts: 271
Thanks: 4

I Ride:
Re: We are not alone.....FI issues.

Originally Posted by DaleEO

IMHO one of the best things you can do is purchase one of the profill drop in filters for your filler neck on your fuel tank to help keep out the dirt.

Dale
x2.

Probably THE best thing in fact. Keep the c**p out of the tank in the first place. Never be without mine.
pegscraper is offline  
December 16th, 2011, 09:04 PM   #5
Senior Member
 
Joined: Dec 2011
From: Brisbane Australia

Posts: 143
Thanks: 93

I Ride: FE650
Re: We are not alone.....FI issues.

The irony here is that over the last ten years I haven't had a single issue with the fuel injection on my Harley. Maybe all the manufactures need to look to Harley for help in making their F.I. systems reliable .
Hoosaberg is offline  
December 17th, 2011, 01:03 AM   #6
Member
 
Joined: Feb 2009
From:

Posts: 36
Thanks: 0

I Ride:
Re: We are not alone.....FI issues.

Originally Posted by Hoosaberg
The irony here is that over the last ten years I haven't had a single issue with the fuel injection on my Harley. Maybe all the manufactures need to look to Harley for help in making their F.I. systems reliable .
Or maybe GasGas. I never had a single worry during my ownership with one.

My Husaberg fuel pump failed at 1200kms and just over a year old (Early 2011 model)
JRDoz is offline  
December 17th, 2011, 02:28 AM   #7
Senior Member
 
Joined: Dec 2010
From: Yorkshire UK

Posts: 271
Thanks: 4

I Ride:
Re: We are not alone.....FI issues.

The FI system on my 04 R1 ran perfectly from day 1. Not so much as a cough in over 24k miles and the fuelling was spot on from tickover to redline. Still running perfectly when I sold it and that's with no tank neck filter and the original fuel filter still in place. The only reason I can see for a manufacturer using the Chinese pumps is lower build cost = more profit. JMO
pegscraper is offline  
December 17th, 2011, 05:30 PM   #8
Member
 
Joined: Dec 2009
From: Colorado

Posts: 83
Thanks: 2

I Ride:
Re: We are not alone.....FI issues.

Originally Posted by pegscraper
The FI system on my 04 R1 ran perfectly from day 1. Not so much as a cough in over 24k miles and the fuelling was spot on from tickover to redline. Still running perfectly when I sold it and that's with no tank neck filter and the original fuel filter still in place. The only reason I can see for a manufacturer using the Chinese pumps is lower build cost = more profit. JMO

I've got a 2000 Suzuki Hayabusa and 2009 FE450 and still no FI issues whatsoever. I know of several Harleys with ongoing FI problems. So there you have it... you never know.



BTW Pegscraper, sorry for your Border Collie loss this past year. Awesome companions. Lost one years ago that was almost twenty. Current one (Enzo) is nine. He is a real joy too.
Busa10 is offline  
January 12th, 2012, 10:23 AM   #9
Senior Member
 
Joined: Oct 2011
From: Holland

Posts: 160
Thanks: 4

I Ride: FE 390 2010
Re: We are not alone.....FI issues.

Perhaps bacteria infection? That may be the reason that it seems to happen so randomly...
Noppy is offline  
January 12th, 2012, 02:07 PM   #10
Member
 
Joined: Aug 2010
From: The land down under

Posts: 79
Thanks: 0

I Ride:
Re: We are not alone.....FI issues.

Comparing road bike and dirt bike fuel systems is a bit of a cop out imho unless you ride your roadie in the scrub.

Dirt bikes are far more susceptible to failure due to the environmental conditions they run in, ie dirt, mud, rough terrain, sand, deep water, all environments that can lead to failure. Basically they get the crap pounded out of them.

I am by no means making excuses for the faults in ktm pumps, they are hit and miss. Hopefully some pump manufacturer can get it right.
And while their at it, they need to sort out the cam chain tentioner as well.
easyrider is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Fuel

Tags
alonefi, issues



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
FE 400 issues wiktor Mechanical 12 June 21st, 2018 01:07 AM
Idle Issues 011 jof062 Husaberg 6 July 5th, 2011 11:38 PM
Land use issues DaleEO Husaberg 1 January 8th, 2008 06:15 AM
couple o issues twitch Mechanical 3 June 23rd, 2005 12:05 PM


Facebook Twitter Google+ RSS Feed