Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
March 6th, 2009, 06:23 AM   #1
Member
 
Joined: Feb 2009
From: Bulgaria

Posts: 56
Thanks: 0

I Ride:
User Setting Tool ECU connection problem

I’m having problem with User Setting Tool. It cannot connect to the ECU. The software is connecting to the UST adapter, and the status of the software is “Waiting for Commandâ€
sabink is offline  
 
March 9th, 2009, 12:23 PM   #2
Junior Member
 
CUL8ER's Avatar
 
Joined: Jun 2005
From:

Posts: 17
Thanks: 0

I Ride:
I also have that problem, the only thing i see in the program is that the IGP is ON, but recognition is failing. Must be something wrong.. i haven't heard anyone got this working so far.
CUL8ER is offline  
March 9th, 2009, 03:50 PM   #3
Senior Member
 
Joined: Jun 2007
From: Mexilhoeira Grande, Portugal (for US citizens; that's a country in Europe)

Posts: 143
Thanks: 0

I Ride:
I have no experience with the UST but I found the reading below, perhaps it is of any help. It is an official statement form KTM/Husaberg.

„Can the customer use the UST without further changes on there bike?“

No. If a customer wants to use the UST on their bike they also have to flash the ECU to a special UST
mapping. This mapping can be downloaded only by the dealer as a .zip-file through Husaberg dealer.net /
webshop in the parts description of the UST (parts/tools/”more”/information/”click here”).
When you want to flash the UST mapping on the ECU the system asks you for entering a special code.
You will get this code (VIN linked) automatically after sending the apply form from the XC-1 software to
the e-mail address diagnostic@husaberg.com .
After entering this code into the XC-1 software the UST mapping can be flashed on the ECU and the bike
can be used with the UST.
Important:
When you apply for the code to flash the UST mapping on the ECU the customer looses the complete
warranty for their bike, no matter if the UST mapping has been flashed to the ECU of the bike or not.You see: clearly a case of: Why easy if we can make it difficult?
dustbite is offline  
March 9th, 2009, 04:13 PM   #4
Member
 
Joined: Feb 2009
From: Bulgaria

Posts: 56
Thanks: 0

I Ride:
Great Info, thanks!
sabink is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
connection, ecu, problem, setting, tool, user



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Playing with the User Setting Tool on a 570 maKe Electrical 14 May 22nd, 2012 11:55 PM
anyone re map their bike with the user setting tool? ratman1 SuperMoto 4 February 20th, 2011 11:14 AM
problem with user setting tool ratman1 SuperMoto 25 December 21st, 2010 11:15 PM
Setting Tool Problem 993sdad Electrical 2 February 24th, 2010 10:55 AM
MY 09 user setting tool dustbite Electrical 6 May 9th, 2009 11:58 AM


Facebook Twitter Google+ RSS Feed