Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
April 27th, 2004, 04:59 PM   #1
Guest
 
Joined:
From:

Posts: n/a
Thanks:

I Ride:
no spark!

Hello, I have a 2001 husaberg FX 470e, and she just quit(no spark) can any one point me in the right direction? stator or coil? can either be tested? I know they are expensive, so i want to be sure. my stator is kind of rusty, I cleaned it, it also has a crack in the plastic casing. any info would be great!
 
 
April 27th, 2004, 05:01 PM   #2
Senior Member
 
Joined: Dec 2002
From: Michigan

Posts: 175
Thanks: 5

I Ride:
Download the hard start guide from the downloads section, this will guide you in the right direction
ENFORCER4 is offline  
April 27th, 2004, 05:21 PM   #3
Site Founder
 
schwim's Avatar
 
Joined: Sep 1998
From: NC, US

Posts: 3,147
Thanks: 50

I Ride: Cannondale Scalpel
Please don't post under "Site Problems" unless you have problems on the site. Please become a member to post in the relevant category.

thanks,
json
schwim is offline  
April 28th, 2004, 04:46 AM   #4
Member
 
fish's Avatar
 
Joined: Oct 2002
From: Brighton/Manchester England

Posts: 56
Thanks: 0

I Ride:
I had a similar problem on a FS650.

Bike running Sat morning, Sun morning nothing.

No spark no go
Checked all! eleccy bits but found no faults. New plug still nothing.

Awayway after removing air filter discovered oil in the inlet boot of the carb. So, off with the carb and gave it a good clean along with the plug.

Put it all together and thrapp

I've since rerouted the rocker breather and sealed the top tube where it connected and have not had the problem since.
fish is offline  
April 29th, 2004, 03:40 PM   #5
Senior Member
 
Joined: Nov 2002
From: Vacaville, California

Posts: 306
Thanks: 0

I Ride:
airhorton,usually it is the stator that fails.we have only had (1) 2001 or newer bike have any coil problems and it was on a bike right out of the crate.sounds like you can visually see a couple imperfections with your stator and that further makes me think there lies your problem.unfortunately it is a very common problem with husabergs.if you can get much over 2 years out of one you are doing something right or just plain lucky.we do have one in stock right now if you want to take the plunge,they are about $300 for that year bike.dan.
Motoxotica is offline  
April 29th, 2004, 04:00 PM   #6
Senior Member
 
Joined: Feb 2003
From: Wilder, ID USA

Posts: 224
Thanks: 0

I Ride:
My stator went out on me and the CDI as well. Im not sure which one went first, really no way to tell. that was a pretty bill.
dave186 is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
spark



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
no spark! scabmachine Electrical 17 February 1st, 2012 04:42 PM
no spark fc 501 99 testaniewicz Electrical 3 May 14th, 2011 12:00 AM
2002 501 weak spark or no spark bergtime Electrical 3 December 11th, 2008 02:44 AM
help got no spark dan2002 Electrical 3 August 28th, 2008 10:39 PM
BETTER SPARK ANKAN Electrical 8 July 31st, 2005 11:24 PM


Facebook Twitter Google+ RSS Feed