Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Thanks Tree2Thanks
  • 1 Post By Jlwojo
  • 1 Post By rikschipp
Reply
 
LinkBack Thread Tools Display Modes
July 5th, 2021, 04:09 PM   #1
Junior Member
 
Joined: Mar 2021
From: Ny

Posts: 6
Thanks: 2

I Ride:
FE570- no power, need help

Hey guys, I went down on a wet log over the weekend that was on an overgrown trail and it was hidden pretty good. After I got up, the whole bike flickered and I moved some of the wiring around behind headlight and it had power again, at the time it wasn't too concerning. I walked it to a better spot and took a break. I turned the key on and there was flat out no power and suspecting wiring issues. It's a rats nest behind the headlight and I'm at work right now and hoping to get an idea of where to test wires.

Thanks
Jlwojo is offline  
 
July 5th, 2021, 10:39 PM   #2
Junior Member
 
Joined: Mar 2021
From: Ny

Posts: 6
Thanks: 2

I Ride:
Yeup.. It was a fuse, I didnt notice it at first.
Thanks from MikeAbe
Jlwojo is offline  
July 7th, 2021, 08:49 PM   #3
Member
 
Joined: Jul 2020
From: tilba nsw australia

Posts: 43
Thanks: 10

I Ride: Berg TE250 '13- gone!KTM 990SMT- gone! Berg FE570 '12 (my dream bike for years!) TY250 TY80 original
Make sure that fuse box and starter relay are sitting correctly on the posts, and that the battery lid is in place properly, including the routing of the battery cables- it's important to get them all fitting together so they don't rub or rattle- can cause all sorts of issues, always when you're miles from nowhere!
Thanks from MikeAbe
rikschipp is offline  
July 8th, 2021, 05:01 PM   #4
Junior Member
 
Joined: Dec 2020
From: Salida, CO

Posts: 4
Thanks: 0

I Ride: 2010 Husaberg FE570
Originally Posted by rikschipp View Post
Make sure that fuse box and starter relay are sitting correctly on the posts, and that the battery lid is in place properly, including the routing of the battery cables- it's important to get them all fitting together so they don't rub or rattle- can cause all sorts of issues, always when you're miles from nowhere!
Is there anything that shows how the wiring gets packed together when reinstalling the subframe/battery tray? Possibly step by step? I have pictures of it when finished, from above, but I am having a tough time putting everything back together this time. Do all of the main wires run along the left side of the subframe?
MikeAbe is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
fe570, power



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 FE570 - how much extra power output do I have? Junkie Electrical 1 August 9th, 2019 09:22 AM
New User - Husaberg FE570 Power Issue Jaffas New Users 4 June 18th, 2018 06:45 AM
Electrical Power on 2011 FE570 T Stretch Husaberg 2 April 19th, 2012 09:49 PM
FE570 - massively down on power GregUK Husaberg 7 September 29th, 2011 12:30 AM
FE570 erratic power delivery at low load BRod Husaberg 2 May 19th, 2011 10:11 AM


Facebook Twitter Google+ RSS Feed