Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
January 8th, 2020, 04:26 AM   #1
Junior Member
 
Joined: Jan 2020
From: N.E Scotland

Posts: 5
Thanks: 1

I Ride: K7 BKing, 86 Harris Mag 2, K4 FE 550 SM
04 FE550 no spark

Hi folks

got an FE550 few days ago, had a play on t now ive no spark

seem to be getting resistance and continuity readings at both the stator and the coil so im suspecting its the cdi unit

cdi number is 80039030000

i believe the bike started life as a 450 but since had the 550 engine transplant

can anybody shed some light as to

a) what the resistance vales shoule be at the stator and coil
b)if theres any way to identify the cdi as being 450 or 550 or if it matters
c)if theres anyway to diagnose the cdi

Thanks in advance folks
Dangerousbrian is offline  
 
January 8th, 2020, 09:03 AM   #2
Senior Member
 
Joined: Oct 2004
From: Reykjavik Iceland

Posts: 275
Thanks: 3

I Ride:
80039030000 is the part number for the rubber holder for the cdi

https://www.google.com/search?q=8003...hrome&ie=UTF-8

If you can find the part no for the cdi you have it should tell from what cc bike it is for.
The_Force is offline  
January 8th, 2020, 09:17 AM   #3
Junior Member
 
Joined: Jan 2020
From: N.E Scotland

Posts: 5
Thanks: 1

I Ride: K7 BKing, 86 Harris Mag 2, K4 FE 550 SM
ah ok mate cheers

ive done a bit of digging about since and i dont think it matters generally which cdi you use, they have slight minor differences but all seem to work on all husabergs
Dangerousbrian is offline  
January 10th, 2020, 05:07 AM   #4
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 16,053
Thanks: 501

I Ride: Husaberg FE501e 2003
so it is a genuine 2004 model with 4 screws in the ignition cover?

very unlucky....

Taffy
Taffy is offline  
January 11th, 2020, 08:38 AM   #5
Junior Member
 
Joined: Jan 2020
From: N.E Scotland

Posts: 5
Thanks: 1

I Ride: K7 BKing, 86 Harris Mag 2, K4 FE 550 SM
Originally Posted by Taffy View Post
so it is a genuine 2004 model with 4 screws in the ignition cover?

very unlucky....

Taffy

My first husaberg mate, feel free to educate me as to why this is unlucky ?
Dangerousbrian is offline  
January 12th, 2020, 10:18 PM   #6
Senior Member
 
Alan's Avatar
 
Joined: Jul 2016
From: Australia, Beechworth, Vic.

Posts: 575
Thanks: 269

I Ride: when I can which isn't often enough. FX450, FE570
Originally Posted by Dangerousbrian View Post
My first husaberg mate, feel free to educate me as to why this is unlucky ?
Hi Brian, welcome to Taffy!
Alan is offline  
January 13th, 2020, 12:18 AM   #7
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 16,053
Thanks: 501

I Ride: Husaberg FE501e 2003
I've never known what Alan's problem is Brian. he seems to make something out of nothing all the time.

OK, the 03 (with 3 screws) has a lot of this problem and the 04 doesn't at all.

cheers

Taffy
Taffy is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
fe550, no spark, spark



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 fe390 weak spark spark falling off magnumsmydog Electrical 50 April 25th, 2018 05:48 PM
Spark Arrestor Options? FE550 KentJ Exhausts 23 February 27th, 2015 09:38 PM
02 400 no spark ChrAJohns0 Electrical 21 June 12th, 2013 04:21 AM
which spark plug for FE550 2004 klaas Electrical 4 April 6th, 2009 11:01 PM
2002 501 weak spark or no spark bergtime Electrical 3 December 11th, 2008 02:44 AM


Facebook Twitter Google+ RSS Feed