Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Thanks Tree2Thanks
  • 2 Post By PABiker
Reply
 
LinkBack Thread Tools Display Modes
July 15th, 2019, 07:29 AM   #1
Junior Member
 
Joined: Jul 2018
From: North Carolina

Posts: 1
Thanks: 0

I Ride:
Question 11í FS570 no power to fuse #3

I picked up a FS570, Iíve got brake lights and turn signals but the headlights, rear running light, highbeam indicator donít work. Iíve tested the lighting wiring harness and it was good, I pulled the light switch from my 390 and still no go. While the bike is running Iím not getting power to fuse #3. Iíve got the wiring diagrams but Iím not sure what Iím looking at.
Reelberg390 is offline  
 
July 15th, 2019, 08:23 AM   #2
Member
 
Joined: Jun 2010
From: Pittsburgh

Posts: 77
Thanks: 14

I Ride:
11í FS570 no power to fuse #3

Remove the headlight bulb and see if that helps, the bulb is known to short blowing the fuse.
Thanks from Rainerio and TXThumper
PABiker is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
11í, fs570, fuse, headlight or taillight, power



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS570 11' Backfire and now power Dieseltwitch Mechanical 5 February 5th, 2017 01:37 PM
Fuse Issues Craig Cook Fuel 4 December 29th, 2015 12:31 AM
Bike lost all power after fuse change 9ball Electrical 3 May 11th, 2015 04:47 PM
starter fuse wardy Electrical 5 December 23rd, 2011 04:44 AM
Blown fuse? ElSnorro Electrical 15 January 5th, 2008 07:39 AM


Facebook Twitter Google+ RSS Feed