Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
July 13th, 2019, 12:48 PM   #1
Junior Member
 
Joined: Oct 2014
From: Capitol of Empire

Posts: 3
Thanks: 0

I Ride:
2011 FE390 Runs Rough

Hello All,

I have a 2011 FE390 that is running really rough.

Before a ride this spring, i was busy doing several things at once and loosely put the oil cap back in the bike. 15 to 20 minutes into the ride (in the rain), I looked down and the cap was off. The bike was also running a little odd, a little rough, under powered, and some cracking from the tail pipe.
I immediately shut it off and hauled back in a truck.

I drained the oil (no visible water), and there was at least a quart that came out so the engine never ran dry. Changed the oil again.

However, the rough running continued. I have replaced the fuel pump (because that is almost always the problem), spark plug and spark plug cable. It is still running very poorly. It will stall if any gas is applied and the clutch is pulled in. If the bike is in neutral, it will run if I open the throttle but cracks A LOT.


The bike also has a map switch installed by the previous owner. I never touch it.

There aren't any Berg mechanics that I trust near me.

Any thoughts on what is happening? I'm pretty sure that it's an electrical or sensor problem...but I can't be sure. The bike is currently at a mechanic but they seem to be stumped as well.

Thanks for any advice you may have.
Daners5150 is offline  
 
July 14th, 2019, 11:53 AM   #2
Member
 
Joined: May 2017
From: United States

Posts: 52
Thanks: 11

I Ride:
I would try cleaning the injector and checking the small cone fuel filter if you still have it in the system.
NoClassic is offline  
July 14th, 2019, 04:50 PM   #3
Member
 
Joined: Oct 2010
From: Oakland

Posts: 36
Thanks: 9

I Ride: 2010 FE390
In my bike I found a kinked fuel line in the tank - might want to check for that if you pull the pump out again.
robinasu is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
2011, fe390, rough, runs



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: 2011 fe390 mxs Classifieds 0 August 22nd, 2016 06:34 AM
For Sale: 2011 fe390 Gila Monster Classifieds 6 August 19th, 2016 04:44 PM
For Sale: 2011 fe390 FE390BERG Classifieds 10 April 7th, 2016 10:56 AM
Best Map for 2011 FE390? djll Husaberg 0 April 28th, 2011 10:50 AM
04 550 runs rough for first mile jmumme Mechanical 11 March 13th, 2009 07:31 PM


Facebook Twitter Google+ RSS Feed