Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
August 7th, 2018, 12:59 AM   #11
Junior Member
 
Joined: Jul 2018
From: Amsterdam (the Netherlands)

Posts: 13
Thanks: 0

I Ride:
Originally Posted by nsman View Post
Have your battery load tested
The berg starts normally with the E-start but even with a broken battery, the voltage over the battery should be above the 13V when the engine is running.
Jermo is offline  
 
August 7th, 2018, 12:25 PM   #12
Senior Member
 
Joined: Apr 2010
From: That funny little race track at the bottom of the world.

Posts: 361
Thanks: 41

I Ride:
The regulator is what determines voltage to the battery.
bergbro is offline  
August 7th, 2018, 02:41 PM   #13
Senior Member
 
nsman's Avatar
 
Joined: Oct 2004
From: nova scotia

Posts: 1,340
Thanks: 14

I Ride:
Originally Posted by Jermo View Post
The berg starts normally with the E-start but even with a broken battery, the voltage over the battery should be above the 13V when the engine is running.
No ,a battery can fail in many ways
a simple load test will rule it out
make this the first test you do,not the last
nsman is offline  
August 8th, 2018, 12:15 PM   #14
Senior Member
 
Joined: Apr 2010
From: That funny little race track at the bottom of the world.

Posts: 361
Thanks: 41

I Ride:
OP has stated the battery was at 12.9v not running and dropped to 11v on startup?
That indicates to me the voltage regulator is not functioning correctly..... rectifier converts ac-dc and the regulator determines the correct amount of charge to go to the battery.
bergbro is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
fs650, issue, stator



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
02 FS650 E low voltage issue ando Electrical 3 August 23rd, 2017 04:57 AM
2002 650 electrical issue.(stator) gregfreefaller Electrical 26 April 28th, 2017 09:51 PM
Stator issue webmonstro Electrical 10 November 22nd, 2016 02:04 PM
95 FE600 possible Stator issue? dkusko Electrical 21 April 17th, 2014 06:18 PM
stator or fuel issue? i thinks stator.. Bergini Electrical 20 April 24th, 2012 03:48 AM


Facebook Twitter Google+ RSS Feed