Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more

LinkBack Thread Tools Display Modes
February 21st, 2018, 01:25 AM   #1
Junior Member
Joined: Feb 2018
From: South Africa

Posts: 1
Thanks: 0

I Ride:
Husaberg 300 TE 2013 not Charging

Good Day

Please assist. I have a Husaberg 300 TE 2013 not Charging, Tested the voltage on both + and - terminals and its not producing any voltage higher then 12.8v. Battery has been tested and working fine. When bike idles or revved no increase in voltage. So I suspect Voltage Regulator gone bad. Now my problem is that I cannot find a replacement as mine has 5 pins and all models from 2014 has 4 pins. Could I use any 5pin 12v voltage regulator to replace mine with as I can't find companies in my Country with OEM placement part.
Or Whom can as contact to assist. Picture have been attached
Attached Thumbnails
Husaberg 300 TE 2013 not Charging-reg.jpg  
jacquesduder is offline  
February 22nd, 2018, 05:00 AM   #2
Junior Member
Joined: May 2017
From: Edmonton, Canada

Posts: 7
Thanks: 2

I Ride:
Get a trail tech stator and new voltage Reg will come with it
SMP220 is offline  

  Husaberg Forum > Mechanical and Technical > Electrical

2013, 300, charging, husaberg

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Husaberg TE300 2013 complete rebuild husaBERG Tech 1 September 30th, 2015 04:46 AM
Want To Buy: 2013 husaberg rekluse brett mccracken Want To Buy 5 April 20th, 2015 06:06 PM
Husaberg ready for the 2013 Dakar JW Adventure Riding 14 August 15th, 2014 12:07 PM
CUSTOM MODIFIED NEW 2013 FE 501 HUSABERG renoktm Marketplace 1 February 24th, 2013 03:37 PM
2013 KTM 350exc SIX DAYS vs 2013 HUSABERG vs 2013 CRF X bontoa Husaberg 3 September 27th, 2012 08:53 AM

Facebook Twitter Google+ RSS Feed