Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Thanks Tree9Thanks
  • 2 Post By jon andersson
  • 2 Post By Uncaged
  • 3 Post By Noubazor
  • 2 Post By Noubazor
Reply
 
LinkBack Thread Tools Display Modes
July 20th, 2017, 08:34 PM   #1
Junior Member
 
Joined: Dec 2015
From: NW PA

Posts: 6
Thanks: 3

I Ride:
HELP! Wiring harness routing 2010 FE390

I'm an idiot. Now that it's out of the way...

I ripped apart the wiring harness on my 2010 FE390 and I can't remember exactly how it routed into the battery/rear sub frame area. Any chance someone has a pic ? The main problem is that I can't mount the tank cuz the main wire is in the way.

Any help would be greatly appreciated. Hoping to ride tomorrow!!

Uncaged is offline  
 
July 20th, 2017, 11:03 PM   #2
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 955
Thanks: 405

I Ride: Two FE570 -12
That is a bit tricky. I forgot to pay attention the first time myself..

I cant take any pictures right now but I'll try to explain.
It is best to start at the batterybox before tierapping anything further to the front so you have enough slack to work with.
The cables going up to the battery and back to the fender should all be squeezed in between the battery compartment and the batterybox on the left side. Try to read the bends how they were and where they want to go. Keep some extra slack in the loom to be able to work them into place. One cable will obviously go to the sensor under the battery box. When you get the cables organized in a nice manner next to the batterybox you still need some friendly force squeezing the box into place while you screw it in place.
Next step is to work the loom low enough so the tank can fit. There is a loom holder at the bottom that you can choose to not use if you like. That can save you a few mm.
When you get it in place hook up the cable to the back brake, and yes it will be dangling loose close to the spring..
The rest will only fit one way.

Hope it helps.
Thanks from tourist and Alan
jon andersson is offline  
July 21st, 2017, 04:36 AM   #3
Junior Member
 
Joined: Dec 2015
From: NW PA

Posts: 6
Thanks: 3

I Ride:
Originally Posted by jon andersson View Post
That is a bit tricky. I forgot to pay attention the first time myself..

I cant take any pictures right now but I'll try to explain.
It is best to start at the batterybox before tierapping anything further to the front so you have enough slack to work with.
The cables going up to the battery and back to the fender should all be squeezed in between the battery compartment and the batterybox on the left side. Try to read the bends how they were and where they want to go. Keep some extra slack in the loom to be able to work them into place. One cable will obviously go to the sensor under the battery box. When you get the cables organized in a nice manner next to the batterybox you still need some friendly force squeezing the box into place while you screw it in place.
Next step is to work the loom low enough so the tank can fit. There is a loom holder at the bottom that you can choose to not use if you like. That can save you a few mm.
When you get it in place hook up the cable to the back brake, and yes it will be dangling loose close to the spring..
The rest will only fit one way.

Hope it helps.
Excellent explanation. Thanks for taking the time to write that up! Kicking myself for not taking "before" pics. I'll snap an "after" pic...I hope

UC

Sent from my SCH-I545 using Tapatalk
Uncaged is offline  
July 21st, 2017, 08:40 AM   #4
Junior Member
 
Joined: Dec 2015
From: NW PA

Posts: 6
Thanks: 3

I Ride:
After hours of pissing around I got the bike back together thanks to mr. Anderson. Stator had failed so battery wasn't charging. I took a few pics of the loon routing in case it helps someone in the future.



Sent from my SCH-I545 using Tapatalk
Thanks from jon andersson and tourist
Uncaged is offline  
July 21st, 2017, 12:26 PM   #5
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 955
Thanks: 405

I Ride: Two FE570 -12
I can see I forgot the cable to the fusebox. Had a feeling something was missing in my explanation
jon andersson is offline  
July 21st, 2017, 04:29 PM   #6
Junior Member
 
Joined: May 2015
From: Belgium

Posts: 25
Thanks: 25

I Ride:
husaberg 450 2009 ==>
Attached Thumbnails
HELP! Wiring harness routing 2010 FE390-1.jpg   HELP! Wiring harness routing 2010 FE390-2.jpg   HELP! Wiring harness routing 2010 FE390-3.jpg   HELP! Wiring harness routing 2010 FE390-4.jpg   HELP! Wiring harness routing 2010 FE390-5.jpg  

HELP! Wiring harness routing 2010 FE390-6.jpg   HELP! Wiring harness routing 2010 FE390-7.jpg   HELP! Wiring harness routing 2010 FE390-8.jpg  
Thanks from jon andersson, tourist and Uncaged
Noubazor is offline  
July 21st, 2017, 04:31 PM   #7
Junior Member
 
Joined: May 2015
From: Belgium

Posts: 25
Thanks: 25

I Ride:
The attached photos are visible ?

next :
Attached Thumbnails
HELP! Wiring harness routing 2010 FE390-9.jpg   HELP! Wiring harness routing 2010 FE390-10.jpg   HELP! Wiring harness routing 2010 FE390-11.jpg   HELP! Wiring harness routing 2010 FE390-12.jpg  
Thanks from jon andersson and tourist
Noubazor is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
2010, fe390, harness, routing, wiring



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
wiring harness/loom Taffy Electrical 0 June 14th, 2017 01:13 AM
My Wiring Harness Dieseltwitch Electrical 3 January 16th, 2015 07:53 AM
Main harness routing pedroFS Electrical 2 September 1st, 2011 09:35 PM
WIring harness 2009 FE450 BRN2RDE Electrical 6 June 15th, 2011 09:24 AM
KTM Wiring Harness - Street maDDtraPPer Electrical 2 November 11th, 2008 12:40 PM


Facebook Twitter Google+ RSS Feed