Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Thanks Tree3Thanks
  • 2 Post By fe390vt
  • 1 Post By Rainerio
Reply
 
LinkBack Thread Tools Display Modes
July 23rd, 2015, 07:03 PM   #1
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 909
Thanks: 216

I Ride: 7 Husabergs two FE570S,FS570 FE390/450,07 FE650,05 FE550,2 Husqvarna's 86 WR400,87 510,09 Buell
Crank position sensor FX450

2011 FX450 Can anyone tell Me about the crank position sensor. Mine might be bad? Bike has spark , compression , fuel pressure good , fuel injector working good cleaned it and checked spray pattern also good. Bike will not start? Doesn't even run bad? No flashing lights. Help

Last edited by Rainerio; August 9th, 2015 at 12:35 PM.
Rainerio is offline  
 
July 23rd, 2015, 08:29 PM   #2
Senior Member
 
Joined: Jul 2011
From: vermont

Posts: 189
Thanks: 31

I Ride: 2011 fe390
zap

You've ruled out kill switch and faulty ground wires behind headlight mask? or a loose terminal. did you jump the wires from the computer interface to see if u get a code? if the bike doesn't start , then it won't trip a code.
think simple first.
fe390vt is offline  
July 23rd, 2015, 08:54 PM   #3
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 909
Thanks: 216

I Ride: 7 Husabergs two FE570S,FS570 FE390/450,07 FE650,05 FE550,2 Husqvarna's 86 WR400,87 510,09 Buell
Bought the bike not running. Pulled plug on kill switch tried it still same thing. What do you do to trip it for codes what wires where? On computer interface. Front Number plate no headlight.
Rainerio is offline  
July 23rd, 2015, 09:36 PM   #4
Senior Member
 
Joined: Jul 2011
From: vermont

Posts: 189
Thanks: 31

I Ride: 2011 fe390
from an old post from davo

Re: Reading FI Error Codes
If you bridge a wire between pins 5 and 6 in the XC1 connector the Berg will stay powered up. I have more detail in this old post:

Bypass power relay for testing electrical on fe 570 -09

EFI light Codes are:
4x long, 5x short = Lambda sensor heater circuit
9x short = Manifold absolute pressure sensor
1x long, 3x short = Intake air temperature
1x long, 2x short = Engine coolant temperature sensor
6x short = Throttle position sensor
1x long, 7x short = Lambda sensor
3x long, 3x short = Injector
2x short = Crankshaft position sensor
3x long, 7x short = Ignition coil
1x long, 5x short = Rollover sensor
4x long, 1x short = Fuel pump relay

xc1 connector is above the battery not sure which ones 5 and 6 are but it may be stamped on the connector if u r lucky , otherwise you'll have to consult the repair manual which can be found somewhere on this site. doing a google search works best.
Thanks from Rainerio and ede
fe390vt is offline  
August 9th, 2015, 12:34 PM   #5
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 909
Thanks: 216

I Ride: 7 Husabergs two FE570S,FS570 FE390/450,07 FE650,05 FE550,2 Husqvarna's 86 WR400,87 510,09 Buell
Crank position sensor is not good works sometimes that's the good news. Compression checked low. The way to check it is to pump air in and look at the gauge don't know what the PSI numbers but when I find out I'll let you guys know. Looks like piston rings broken hope that's all it is. Bike was ridden hard so going to pull engine slipped and look it over to see if any other problems come up. Bought the bike to learn about 70d motors fuel injection computers mapping and I am big time. Glad I'm retired. By the way thanks fe390vt checked all you had said just got unlucky with this one but in the end going to know a lot. When I take out any of the Husaberg's won't be afraid of them if they have a problem.

Last edited by Rainerio; August 9th, 2015 at 12:41 PM.
Rainerio is offline  
July 23rd, 2018, 11:24 AM   #6
Junior Member
 
Joined: Apr 2018
From: Florida

Posts: 17
Thanks: 0

I Ride:
What ended up being your issue? I'm having the exact same symptoms but no codes
bayside08 is offline  
July 24th, 2018, 03:13 PM   #7
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 909
Thanks: 216

I Ride: 7 Husabergs two FE570S,FS570 FE390/450,07 FE650,05 FE550,2 Husqvarna's 86 WR400,87 510,09 Buell
Took it to a dealer he couldn't get running? pull engine haven't taken it apart let. Retired you'd think I have the time?
Thanks from tourist
Rainerio is offline  
July 25th, 2018, 03:31 AM   #8
Senior Member
 
Alan's Avatar
 
Joined: Jul 2016
From: Australia, Beechworth, Vic.

Posts: 440
Thanks: 222

I Ride: when I can which isn't often enough. FX450, FE570
Originally Posted by Rainerio View Post
Took it to a dealer he couldn't get running? pull engine haven't taken it apart let. Retired you'd think I have the time?
So what did you find?
Alan is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
crank, fx450, position, sensor



Search tags for this page
Click on a term to search for related topics.
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
70 deg. single spark throttle position sensor fe390vt Electrical 10 September 27th, 2016 09:22 PM
Throttle position sensor DaleEO Fuel 11 May 4th, 2009 10:47 AM
crank locking bolt and crank twist bushmechanic Mechanical 25 February 6th, 2009 01:02 PM
crank pin fitment and crank twist especially on the 650's! Taffy Mechanical 2 November 7th, 2008 04:41 PM
Throttle Position Sensor Wyatt Fuel 5 November 27th, 2006 07:58 AM


Facebook Twitter Google+ RSS Feed