Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
June 7th, 2015, 04:21 AM   #1
Member
 
Joined: Mar 2015
From: Bradford, England

Posts: 97
Thanks: 20

I Ride: FE450 2009
Fe450 stall

Hi all. Was riding in my garden yesterday and after an hour or so the bike started stalking occasionally on idle. I pulled up and listed the to the idle. Occasionally it sounded like it was going to stop, a bit like a momentary pause then carries on. I imagine no fire on a stroke?

What's first things to check? Fuel filter / plug

It's an 09 fe450

Cheers
Mordzy is offline  
 
June 7th, 2015, 07:13 AM   #2
Senior Member
 
Joined: Jul 2011
From: vermont

Posts: 189
Thanks: 31

I Ride: 2011 fe390
check where your plug cap connects to the plug wire. Tends to get wet and corrode over time. I usually cut off about 8mm and rescrew..
fe390vt is offline  
June 11th, 2015, 11:10 AM   #3
Member
 
Joined: Mar 2015
From: Bradford, England

Posts: 97
Thanks: 20

I Ride: FE450 2009
Thanks. I've had a look and wire looks ok...
Mordzy is offline  
June 11th, 2015, 11:48 PM   #4
Member
 
Joined: May 2012
From: Winchester, Hampshire, UK

Posts: 47
Thanks: 9

I Ride: FE570 2012
Had exactly the same problem with my 2012 570, it was driving me nuts. After a few hours at the local track was where it all started happening. Then after every wash, river crossing or a long ride, when idling it sounded like it was about to cut out, then it finally would. The local KTM Husa dealer knew all about it. Aparently the plug caps on our bikes are notorious for failing. Even though the connection looks fine, it's all clean and dry, the insulation breaks down when hot or even the slightest moisture gets inside the cap. He replaced it with a brand new version and the problem has disappeared. Hope this helps.
FredE is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
fe450, stall



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting after a stall? clintovsina Husaberg 6 November 26th, 2013 05:34 AM
Starts off the button except when I stall on a hill ? Danielson Fuel 5 April 18th, 2008 04:34 AM
High speed stall? SIRR1 Fuel 5 May 6th, 2005 02:16 PM


Facebook Twitter Google+ RSS Feed