Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
May 16th, 2015, 12:00 PM   #1
Junior Member
 
Joined: Sep 2013
From: Maidstone

Posts: 26
Thanks: 2

I Ride: Husaberg fe 501
Yet again no spark I no ?

Hi guys
I've got no spark on my fs 650 ,I've put new stator on and new ht coil but still nothing ,I've checked earths and move to better place, I bought the stator and coil from electrix world and I've sent stator back and they sent me another and still nothing anything else that I've missed guys that you can think of,the new ht coil comes in two separate halves cdi then ht coil instead of one single ,electrix world gets it from hpi in Belgium if this helps has someone else had the same problem ?
Many thanks Mark
Husamark is offline  
 
May 16th, 2015, 02:36 PM   #2
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 960
Thanks: 235

I Ride: 8 Berg’s 2005-2011 2 Husky’s 1986&7 2009 Buell & 2006 Ducati
See if all wires are good with a test meter. See if ohms are good on coil,stator. Don't ask me what the ohms should be ask the seller. I know this is stupid but check kill switch is not earthed

Last edited by Rainerio; May 16th, 2015 at 02:48 PM.
Rainerio is offline  
May 17th, 2015, 12:34 PM   #3
Junior Member
 
Joined: Sep 2013
From: Maidstone

Posts: 26
Thanks: 2

I Ride: Husaberg fe 501
Stator

hi mate
Cheers for reply I've checked kill switch totally disconnected,I've got nothing else connected just 3 wires coming from stator to the new cdi unit and then to coil ,this is the second stator from electrix world the first one they said it wasn't compatible with the new cdi and coil set up something about the diod in it so they sent me another the next day and still nothing the earths are all good ? Thought it would of been sorted after 400 spent ,maybe I will buy another fly wheel or send ht coil and cdi back for another, I don't no I've tried everything people have done on forum with no luck ,I still think the stator don't work with the cdi and ht coil ?
Husamark is offline  
May 17th, 2015, 04:07 PM   #4
Senior Member
 
Rainerio's Avatar
 
Joined: Jun 2013
From: San Francisco CA. USA

Posts: 960
Thanks: 235

I Ride: 8 Berg’s 2005-2011 2 Husky’s 1986&7 2009 Buell & 2006 Ducati
All the wires meter out OK. maybe F'ed up spark plug take a look ?
Rainerio is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
spark



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
no spark! nikolz12 Electrical 4 March 31st, 2015 11:26 PM
no spark! scabmachine Electrical 17 February 1st, 2012 04:42 PM
2002 501 weak spark or no spark bergtime Electrical 3 December 11th, 2008 02:44 AM
When does it spark surfdude Mechanical 11 May 18th, 2008 11:35 AM
BETTER SPARK ANKAN Electrical 8 July 31st, 2005 11:24 PM


Facebook Twitter Google+ RSS Feed