Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
March 17th, 2015, 04:38 PM   #1
Member
 
Joined: Nov 2014
From: Australia

Posts: 75
Thanks: 35

I Ride:
Mystery starting problem, something simple?

2004 Husaberg FS650e

Hi all, of late my bike will only start on the button with a jump start or a top off from the charger, a problem that I put down to a faulty and old battery. So I replaced it yesterday with a battery with slightly more cold crank amps and assumed that would be the end of it.

I got about 8 seconds total of life out of it before it was back to its old condition; where it would attempt to turn it over but just fell on its face.

I'm confident that the starter is ok because when it gets proper power it turns over fine. The generator was the next suspect but it is getting charge to the battery, I'm starting to think it could be a faulty connection somewhere. Any ideas?
LemoneyF is offline  
 
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
mystery, problem, simple, starting



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
501 fe starting problem iand600 Mechanical 4 February 1st, 2009 02:24 PM
97 FE 600 Starting / Running Problem Mechanical 5 June 19th, 2008 06:16 AM
Starting problem. storm Electrical 4 October 7th, 2007 12:40 PM
96 600 starting problem jonesinmexico Fuel 6 December 24th, 2006 06:55 AM
Mystery problem - one cure is a gallon of 4star and a match! chris_notts Mechanical 8 March 20th, 2006 01:01 PM


Facebook Twitter Google+ RSS Feed