Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Thanks Tree1Thanks
  • 1 Post By husabutt
Reply
 
LinkBack Thread Tools Display Modes
September 6th, 2014, 05:10 PM   #1
Senior Member
 
husabutt's Avatar
 
Joined: Feb 2003
From: Escondido, Ca. USA

Posts: 3,110
Thanks: 334

I Ride: 2005 Fe450,2001 Fx470,1997 Fx600
97 600 Fuse Blowing

Reassembling after doing the top end. Changed frames, repainted.

I tested with a car battery the first time and the motor spun fine. It took a few minutes after I pressed the starter button before the starter began spinning the motor. I also thought it was odd that when I turned the key to the on position I didn't hear the familiar click of the power relay engaging.

Today I filled all of the fluids and was attempting to start it. This time as soon as I connected the cables, with the key in the off position (still using a car battery and jumper cables) the 10 amp fuse blew. I thought that maybe it wasn't a good idea to use a car battery so, I hooked up the new battery that had been charged and ready to go. Same thing. Blew the fuse as soon as I hooked the battery up. Four fuses trashed.

It worked fine last week.

There is only one fuse on this bike and it goes between a positive wire that is connected to the positive cable, where it attaches to the starter solenoid, and runs to the power relay.

My guess is that it the power relay has given up the ghost. Does anyone know how to test the power relay or had this happen to them before?

Last edited by husabutt; September 6th, 2014 at 08:34 PM.
husabutt is offline  
 
September 7th, 2014, 08:12 PM   #2
Senior Member
 
husabutt's Avatar
 
Joined: Feb 2003
From: Escondido, Ca. USA

Posts: 3,110
Thanks: 334

I Ride: 2005 Fe450,2001 Fx470,1997 Fx600
A start button wire coming out of the throttle housing got pinched and was grounding out on the handlebar.

I did purchase a new power relay and try that first.

Here is the NAPA Auto Parts P.N. which is a perfect match for the OEM Bosch unit. AR204 $13.49

Original Bosch Part Number: 0332 019 150
Thanks from tourist
husabutt is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
600, blowing, fuse



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blowing Fuse 4 on Start up - fe570 bearded burbler Electrical 6 April 29th, 2015 03:40 PM
High beam blowing fuse every time. gjws Electrical 8 June 23rd, 2013 04:54 PM
radiator fan fuse keeps blowing fljar Husaberg 19 February 17th, 2012 07:04 PM
Headlight Fuse #3 Blowing JakeB Electrical 2 January 23rd, 2012 06:17 AM
Starter Motor Fuse Keeps Blowing HusaSmith Electrical 3 October 10th, 2010 01:41 PM


Facebook Twitter Google+ RSS Feed