Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
December 25th, 2013, 04:29 AM   #1
Junior Member
 
Joined: Dec 2013
From: Italy

Posts: 6
Thanks: 0

I Ride:
FE390-2010: Battery area pics

Hi to all, this is my first post from Italy and it's because I've got a problem.
The bike is an FE390 my2010 (EU), and few months ago I completely removed the battery, the tank,the rear plastic chassis, cables and many other parts for a deep cleaning.
I'd to be sure the cables now are in the right position, because I think the seats doesnt lock properly.
Please can somebody take some pictures of the battery and cables just around it?
Is just to check if I properly mounted on all the components.
Thank you for your help and sorry for my bad english.
Happy Christmas.

Bergfe390
bergfe390 is offline  
 
December 25th, 2013, 03:14 PM   #2
Senior Member
 
Joined: Nov 2010
From: Salt Lake City, UT

Posts: 253
Thanks: 4

I Ride:
Re: FE390-2010: Battery area pics

Here are a few:





DeeG is offline  
December 25th, 2013, 03:18 PM   #3
Senior Member
 
Joined: Nov 2010
From: Salt Lake City, UT

Posts: 253
Thanks: 4

I Ride:
Re: FE390-2010: Battery area pics

Make sure all four seat hooks seat properly; two in the front, and two in the middle. It is common for these seats to squash out flat, and then it is hard to get all four hooks lined up. You can tell if they are locked in place by trying to lift the front of the seat and each side near the middle. If it is correctly mounted, it will be snug. If not, it will lift up.

To fix it, just put the seat on the ground on its side, then kneel on it and squeeze to make it narrow again.
DeeG is offline  
December 26th, 2013, 01:31 AM   #4
Junior Member
 
Joined: Dec 2013
From: Italy

Posts: 6
Thanks: 0

I Ride:
Re: FE390-2010: Battery area pics

Thank you DeeG I apreciate.
The problem is when I mount the seat it properly fits: even If I try to lift it (front and middle) it's ok.
After a short ride, it lift up in front side.
I will also try to change the seat: I've got a couple.
Thank you again.
Bergfe390
bergfe390 is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
area, battery, pics



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 or 2011 FE390? doolin64 Husaberg 30 March 27th, 2014 04:16 AM
2010 FE390 Won't Start pmdparts Mechanical 4 August 19th, 2013 03:42 PM
New Husa FE390-Battery won't hold charge. 4ReelMoto Electrical 9 August 5th, 2012 04:45 PM
Severed Battery Terminal - '10 FE390 JohnnyQuest Electrical 2 April 16th, 2011 06:57 AM
My new 2010 FE390 newbie Husaberg 3 June 24th, 2010 09:05 PM


Facebook Twitter Google+ RSS Feed