Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
July 22nd, 2012, 02:37 PM   #1
Junior Member
 
Joined: Jun 2012
From:

Posts: 11
Thanks: 0

I Ride:
electrical problem no headlight, no taillight

My headlight, taillight, and licence plate lights don't function. The #3 fuse is OK. There is no 12 volts at the #3 fuse. Everything else is good. Any ideas?
jonbrogers is offline  
 
July 22nd, 2012, 02:40 PM   #2
Junior Member
 
Joined: Jun 2012
From:

Posts: 11
Thanks: 0

I Ride:
Re: electrical problem no headlight, no taillight

Sorry, this is a 2011 570. I replaced the exhaust system with FMF, so had the gas tank off and move the wiring around quite a bit.
jonbrogers is offline  
July 22nd, 2012, 02:41 PM   #3
Junior Member
 
Joined: Jun 2012
From:

Posts: 11
Thanks: 0

I Ride:
Re: electrical problem no headlight, no taillight

Where can I get a wiring diagram for this bike.
jonbrogers is offline  
July 23rd, 2012, 05:57 AM   #4
Member
 
Joined: Mar 2011
From: Blue Mountains NSW Australia

Posts: 56
Thanks: 3

I Ride: 2005 FE650E, 2005 FS650E
Re: electrical problem no headlight, no taillight

I had this reply typed out tried to attach a Husaberg 570 Repair Manual and the screen just went blank.

Anyway, what I had said was that I had exactly the same problem on my 2009 570. I had double checked all the fuses had been placed correctly (as some are just blank spare fuse holders) and after a lot of searching found that the power was getting to the left hand side switch block but was not being distributed back from the switch block anywhere. I am luckier than most to have a 2004 650 I am thinking of rebuilding so I pinched the switch block off that bike and replaced the one on the 570 and it all worked perfectly.
As the headlight section of the switch block is rivetted (actually their like brass eyelets) together I will at some time drill these out just to see what has stopped the connections being mad inside.
Hope that at least gives you something to look at.
Regards

Anthony
anthonys4691 is offline  
July 23rd, 2012, 07:31 AM   #5
Junior Member
 
Joined: Jun 2012
From:

Posts: 11
Thanks: 0

I Ride:
Re: electrical problem no headlight, no taillight

Thanks, Anthony. I take a look at that. It was where I was headed. I wished I had a wiring diagram, but this isn't that complex.
jonbrogers is offline  
July 23rd, 2012, 07:32 AM   #6
Junior Member
 
Joined: Jun 2012
From:

Posts: 11
Thanks: 0

I Ride:
Re: electrical problem no headlight, no taillight

Where did you get the repair manual. Dealer or elsewhere?
jonbrogers is offline  
July 23rd, 2012, 11:21 PM   #7
Member
 
Joined: Mar 2011
From: Blue Mountains NSW Australia

Posts: 56
Thanks: 3

I Ride: 2005 FE650E, 2005 FS650E
Re: electrical problem no headlight, no taillight

If I remember correctly I just googled up "Husaberg repair manual" on the net.

I know I didn't pay for one. I am currently traveling for work but if you' d like to send me your direct email address I will forward the document to you directly. Its a large PDF document and the wiring diagrams are in the last section.

Regards,

Anthony
anthonys4691 is offline  
September 6th, 2012, 05:25 PM   #8
Junior Member
 
Joined: Mar 2012
From:

Posts: 2
Thanks: 0

I Ride:
Re: electrical problem no headlight, no taillight

Not sure if you have the same issue I did or not but have a look: http://www.husaberg.org/forum/viewto...136643#p136643
OsoBlanco is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
electrical, headlight, problem, taillight



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fitting current model KTM headlight & LED taillight to FS650 motofreak Electrical 8 September 9th, 2013 06:05 AM
05 550 fe Electrical Problem jimmythehat Electrical 0 June 1st, 2012 07:56 PM
2009 fe570 headlight/taillight not working. iwl67 Electrical 3 December 14th, 2010 07:36 PM
09/fe 450 electrical problem johny Electrical 13 November 27th, 2010 11:36 PM
Electrical Problem kadlec Husaberg 1 July 18th, 2007 09:43 PM


Facebook Twitter Google+ RSS Feed