Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
December 14th, 2010, 05:55 PM   #1
Junior Member
 
Joined: Aug 2010
From:

Posts: 3
Thanks: 0

I Ride:
2009 fe570 headlight/taillight not working.

just bought an 09 fe 570. it didnt come with the headlight and taillight so i bought them seperate. \the dealer told me that they would plug in and work. False, no luck. Anybody know what may be the problem? \all the fuses are good, wires connected, bulbs good, lots of voltage etc. Any help would be appreciated, thanks.
iwl67 is offline  
 
December 14th, 2010, 06:07 PM   #2
Junior Member
 
Joined: Oct 2010
From: Maple Ridge BC Canada

Posts: 15
Thanks: 0

I Ride:
Re: 2009 fe570 headlight/taillight not working.

Headlight switch? Fire up the bike.
Big Booger is offline  
December 14th, 2010, 06:17 PM   #3
Junior Member
 
Joined: Aug 2010
From:

Posts: 3
Thanks: 0

I Ride:
Re: 2009 fe570 headlight/taillight not working.

Thanks for that but it doesnt work with the bike running. It doesnt have a headlight switch. The lights just plug into the existing wiring thats there.
iwl67 is offline  
December 14th, 2010, 07:36 PM   #4
Junior Member
 
Joined: Aug 2010
From:

Posts: 21
Thanks: 0

I Ride:
Re: 2009 fe570 headlight/taillight not working.

09's didn't come with a headlight switch. You do need a headlight switch.

You could break out a voltmeter and see what's going on. Find out where 12v is and wire up your own switch to fire the headlight/taillight.

I would recommend getting the OEM headlight switch.

I did my 09 with all OEM parts for everything including signal lights, flasher relay, and all wiring harnesses. Looks like a factory 2011 bike and was a dead simple install....not to mention no soldering, no extra wires, and dead easy to troubleshoot should anything go wrong.
pistolpete77 is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
2009, fe570, headlight or taillight, working



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
fe570 themo fan stopped working buffalo450 Cooling Systems 17 June 5th, 2015 08:56 AM
Fitting current model KTM headlight & LED taillight to FS650 motofreak Electrical 8 September 9th, 2013 06:05 AM
Headlight not working ChrAJohns0 Electrical 0 September 20th, 2012 07:22 AM
electrical problem no headlight, no taillight jonbrogers Electrical 7 September 6th, 2012 05:25 PM
2009 headlight mg Electrical 7 May 10th, 2009 03:14 PM


Facebook Twitter Google+ RSS Feed