Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
May 15th, 2010, 10:50 PM   #1
Junior Member
 
Joined: Feb 2010
From: Sydney Australia

Posts: 18
Thanks: 0

I Ride:
Another battery not charging

hey guys,

Tried to read some of the older posts on this subject, but couldn't find anything specific to my problem.

It seems my battery is not charging properly to a point where the electric starter won't tick over anymore. I tested the power on the battery and whilst the engine is not running the charge was 11.8V, whilst the engine was running the charge was 12.8V. When i switched off the engine again the voltage dropped back to 12.2 and decreasing.

Any ideas? do I need a new battery? is the generator not generating enough volts? Any advice is very welcome.
goin9myway is offline  
 
May 15th, 2010, 11:11 PM   #2
Senior Member
 
Joined: Nov 2008
From: Brisbane, Australia.

Posts: 140
Thanks: 0

I Ride:
Re: Another battery not charging

Mate I'd suggest your battery might be farked. The fact that the battery voltage without the bike running is so low (11.8V) doesn't look good. Also the fact the voltage falls off so quickly after stopping the engine says this. I would have thought you should be seeing closer to 14V with the bike running and charging though. Was the bike at idle when you measured this? I'd be holding it at about 3-3500rpm and checking the charging voltage then. The stator won't be putting out much juice at idle. Do you know how old the battery is? I got 2 yrs out of my last Yuasa and thought I'd done well.
BoneGraft is offline  
May 15th, 2010, 11:15 PM   #3
Moderator
 
berger's Avatar
 
Joined: Apr 2002
From: Phoenix Arizona

Posts: 3,152
Thanks: 10

I Ride: 2010 FX450
Re: Another battery not charging

Replace the battery and install a battery tender when not in use.
berger is offline  
May 16th, 2010, 01:15 AM   #4
Junior Member
 
Joined: Feb 2010
From: Sydney Australia

Posts: 18
Thanks: 0

I Ride:
Re: Another battery not charging

thanks for the replies guys The 12.8V is measured at idle and higher in the revs (with the hot start on and application of throttle)

So the battery is probably gone, i'll get a replacement...

But 12.8V is also on the low side? the manual says 13v =-0.5V, i'll check the voltage regulator some more
goin9myway is offline  
May 16th, 2010, 01:27 AM   #5
Senior Member
 
Joined: Nov 2008
From: Brisbane, Australia.

Posts: 140
Thanks: 0

I Ride:
Re: Another battery not charging

Well if the manual says 13V + or - 0.5V then 12.8 is just fine. Try a new battery.
BoneGraft is offline  
May 16th, 2010, 01:37 AM   #6
Junior Member
 
Joined: Feb 2010
From: Sydney Australia

Posts: 18
Thanks: 0

I Ride:
Re: Another battery not charging

hehehe maybe i should have checked the repair manual before posting eh
goin9myway is offline  
May 16th, 2010, 01:53 AM   #7
Junior Member
 
Joined: Feb 2010
From: Sydney Australia

Posts: 18
Thanks: 0

I Ride:
Re: Another battery not charging

Originally Posted by BoneGraft
Do you know how old the battery is? I got 2 yrs out of my last Yuasa and thought I'd done well.
Btw, do you only get 2 years out of a battery?? thats less then i expected
goin9myway is offline  
May 16th, 2010, 02:58 AM   #8
Senior Member
 
Joined: Nov 2008
From: Brisbane, Australia.

Posts: 140
Thanks: 0

I Ride:
Re: Another battery not charging

I ride my bike almost daily so if you take that as 300+ days x 2+ starts/day x 2 years thats 1200+ starts. Pretty good going for a tiny battery starting a 650 thumper imho....My battery was still going when I changed it, just getting a little lazy. It now lives in a 50cc scooter and does the job still.
BoneGraft is offline  
May 16th, 2010, 03:43 AM   #9
Junior Member
 
Joined: Feb 2010
From: Sydney Australia

Posts: 18
Thanks: 0

I Ride:
Re: Another battery not charging

Mhh my bike only gets ridden in the weekend and I've had to use the kickstarter for a while. I remember the previous owner mentioning it went through a few batteries in its warranty period...
goin9myway is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
battery, charging



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery not charging? jmumme Electrical 16 May 6th, 2010 02:53 PM
FE 400 02' battery charging - YTZ14S zaga Electrical 4 May 11th, 2009 08:53 AM
battery charging homerberg Electrical 5 June 26th, 2007 12:35 PM
Battery Charging Problems Horto Electrical 5 July 10th, 2005 07:26 AM
02 650fe not charging battery... ajt Electrical 11 September 22nd, 2004 10:57 PM


Facebook Twitter Google+ RSS Feed