Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Electrical

Electrical Electrical Forum - wiring and more


Reply
 
LinkBack Thread Tools Display Modes
October 30th, 2009, 09:08 AM   #1
Member
 
Joined: May 2009
From: Croatia

Posts: 42
Thanks: 0

I Ride:
CDI repair questions

As you may know i have non working CDI.
I found a schematic for some CDI on internet and i got it assembled today. I connected it to a Yamaha HT coil and it gives a beautiful bright 1 cm spark but when i try it on bike it won't start... a
Here are pictures of my home made CDI unit



Then i broke off the plastic from below of original SEM unit to try to fix it but i don't know what part may be broken, i tested diodes and they are OK.
Does anyone have experience in repairing this CDI units? What is problem with them and what part is weak so Electrex stator fries it?

I don't have money to buy a new one so i'm out of options, i have to repair it somehow. Tomorow i'll try to break the plastic from the top of the unit, maybe i can find something there.

Oh and by the way i'm selling my home made CDI , it may work on a 2 stroke bike and maybe on some 4 stroke
wiktor is offline  
 
October 30th, 2009, 10:10 PM   #2
Senior Member
 
bushmechanic's Avatar
 
Joined: Jun 2007
From: south east WA Australia

Posts: 3,860
Thanks: 1195

I Ride: 2008 700FK, 2002 628FST
RE: CDI repair questions

I pulled apart the CDI on my yz80 when I was 12, soaked it in paint thinners to soften the glue they dunked it in and scraped it away then I tried to draw the circuit from looking at the board and components

eventually just started changing the main bits, bigger capacitors, new diodes and a new three legged thingy

it worked in the end but the main problem was the source coil

can you get an aftermarket programable cdi? or maybe a circuit for one so you can change the curve, I'd like one of those.
bushmechanic is online now  
October 31st, 2009, 12:25 AM   #3
Member
 
Joined: May 2009
From: Croatia

Posts: 42
Thanks: 0

I Ride:
Re: RE: CDI repair questions

Originally Posted by bushmechanic
I pulled apart the CDI on my yz80 when I was 12, soaked it in paint thinners to soften the glue they dunked it in and scraped it away then I tried to draw the circuit from looking at the board and components

eventually just started changing the main bits, bigger capacitors, new diodes and a new three legged thingy

it worked in the end but the main problem was the source coil

can you get an aftermarket programable cdi? or maybe a circuit for one so you can change the curve, I'd like one of those.
I will try to repair my CDI and if i don't suceed i'll be making a digital CDI, i have schematic for one and "only" thing i need to do is find out best ignition angles at various RPM.
wiktor is offline  
October 31st, 2009, 05:11 AM   #4
Senior Member
 
Joined: Nov 2008
From: Turkey

Posts: 100
Thanks: 8

I Ride: FE470, TXTPRO250, CBR600RR
RE: Re: RE: CDI repair questions

Hey wictor.nice dud job :P but you should know that your ignition trigger coil gives two adjacent signals 60degree apart from each other because the flywheel has two magnets for triggering.I recommend you be using a hall effect sensor for ignition trigger for your next digital cdi unit. try replacing the scr and zener diode and other diodes on your current sem ignition module.post here a pic of your opened sem module.
Faust is offline  
October 28th, 2010, 02:06 PM   #5
Junior Member
 
Joined: Oct 2010
From: Sunny Cornwall with silkolene aromas

Posts: 1
Thanks: 0

I Ride:
Unpotting, not plants

I had this SEM Ignition module (CDI) fail a month or so ago after running it with an Electex stator on a ktm for a couple of years. I've replaced it with a new CDI and I've just had my old genuine stator rewound by Bradford ignitions in spain, so hopefully it the new cdi should last ok

I've spent a week or two unpotting the failed one just to have a look, when it failed my bike started to loose top end power and then refused to start when I stopped it. When investigating problem there was only a very weak spark so I was thinking this might be the capacitor? This all went down hill within a matter of ten minutes, it now starts better than it has ever done with the new module.







I thought some of the very clever members on this very good forum might be interested in seeing the bare item
I could identify some of the compents and numbers on them if your interested, I might try repairing it for a spare if I ever have some spare time and can get the spares. The main capacitor is 68micro F 400v but it doesn't say if ac or dc on voltage rating.

The small component between the diodes broke as I was removing the potting, it was blue and probably a zenor diode. Does anyone know the exact spec of this and its direction? I'm not an expert in electronics

The small square blue item at the top left of board has no markings but looks like another capacitor?
Professor is offline  
October 28th, 2010, 11:46 PM   #6
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,615
Thanks: 441

I Ride: Husaberg FE501e 2003
Re: CDI repair questions

probably our best mind here for electrics is the greek 'OYK'. try dropping him a line.

regards

Taffy
Taffy is online now  
Reply

  Husaberg Forum > Mechanical and Technical > Electrical

Tags
cdi, questions, repair



Search tags for this page
Click on a term to search for related topics.
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fe 570 Conrod repair kit berglsmerg Mechanical 6 July 14th, 2013 07:11 AM
2008 FE550 - questions, questions, questions... Hawaii-Rider Husaberg 6 March 1st, 2012 01:11 PM
conrod repair kit bulgarian Husaberg 1 April 5th, 2011 01:46 PM
Repair Manual Berg999 Husaberg 3 April 1st, 2011 11:53 AM
repair manual the_doctor Mechanical 9 June 26th, 2005 11:19 AM


Facebook Twitter Google+ RSS Feed