Husaberg Forum

Husaberg Forum (http://husaberg.org/husaberg-forums.php)
-   Cooling Systems (http://husaberg.org/cooling-systems/)
-   -   Leaking Rad Caps (http://husaberg.org/cooling-systems/24801-leaking-rad-caps.html)

KentJ January 22nd, 2018 09:44 AM

Leaking Rad Caps
 
Hey all,

I was pressure testing my coolant system and found that my rad cap was not holding pressure. It bled out through the overflow almost immediately as I was adding pressure. I bought a new 1.4 bar cap and itís doing the same thing. Anything above 5 PSI (.34 Bar) or so and it purges.

The pressure tester I made just tees into the coolant line above the thermostat and has a schrader valve on it so itís easy to pressurize with compressed air. I used a tire filler with a gauge so I could avoid over-pressurizing it. I measured the residual pressure with a 0-15psi gauge so I donít think itís my measuring thatís out. As far as I can tell it never held pressure on the trails either, this bike is constantly bubbling into the overflow.

Whatís going on??? The new cap leaks. The old cap leaks and it was only a year or so old. The filler neck looks OK, it feels smooth inside. Does the rad cap need to be hot to seal? Is the cap meant to be water-tight but not air-tight?

-Kent

Taffy January 22nd, 2018 11:45 PM

it has to be the correct height and depth to creat pressure downwards onto the seal face.

clean the surface up and and watch for the seal catching on the lip edge of the overflow hole.

regards

taffy

KentJ January 24th, 2018 10:56 AM

I found my old, old cap and compared. They are not the same...

Old one on left:
https://i.imgur.com/l4eUCoJ.jpg

The old cap holds pressure OK. Both new caps, PN 58035016000 from the parts fiche, do not. Depth and diameter measured the same. Not sure about spring pressure.

Is there a different PN I should be using to get the right part?

-Kent

Taffy January 24th, 2018 11:32 AM

oh so was I right then? only if I was right you might say something like; 'thanks Taffy'?

so it couldn't have been right then i guess.

Taffy

Huskyfatman January 24th, 2018 04:47 PM

http://treasurestatelifestyles.com/w...knievel1-2.jpg

Thank you! Thank you very much!!!

Taffy January 24th, 2018 11:28 PM

Manners cost nothing.....

taffy

KentJ January 25th, 2018 08:20 AM

Sure, thanks, Taffy. I always appreciate it when people respond to my questions in an effort to help me out.

But, I’m not sure what you’re getting so excited about, your diagnosis wasn’t exactly spot on. You made some suggestions, but if you read my post the problem appears to come from a difference in cap designs. The old cap works OK and the new caps don’t, despite being in good condition and the correct OEM part.

Cheers,

-Kent

Taffy January 25th, 2018 08:36 AM

Quote:

Originally Posted by Taffy (Post 184553)
it has to be the correct height and depth to creat pressure downwards onto the seal face.

:p :p :p

TomTom January 26th, 2018 05:15 AM

Quote:

Originally Posted by Taffy (Post 184568)
Manners cost nothing.....

taffy

Youre the holy grail of manners :giggle:

bushmechanic January 26th, 2018 04:16 PM

Quote:

Originally Posted by Taffy (Post 184568)
Manners cost nothing.....

taffy

except when you loose customers ;)


All times are GMT -8. The time now is 06:48 PM.

Copyright © 2020 Husaberg Forum. All rights reserved.