Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Cooling Systems

Cooling Systems Cooling Systems - Radiators, Water Pumps, Fans, Coolant, etc.


Reply
 
LinkBack Thread Tools Display Modes
June 16th, 2017, 09:16 PM   #1
Junior Member
 
Joined: Jun 2017
From: Vancouver island

Posts: 1
Thanks: 0

I Ride: 08 Fe550
Unhappy 2008 FE550 Did I install the WP seal wrong?

Sorry for beating the dead horse, this is my first post and a long one(sorry in advance). I just bought this bike last week went for 2 small rides and I was amazed how snappy and responsive the bike is, already in love with the thing but sadly also already having issues.
The previous owner brought it to me with the rad and cooling system full of straight water. Naturally I wanted to test ride the bike and make sure everything was in working order after checking all fluids and doing a pretty thorough visual inspection but I didn't have coolant on hand. So I took it for a super small ride around my block and came back and gave him his cash and he took off,before the first ride I drained the water and filled the bike with coolant.
the first ride went fine but on my 2nd ride I had noticed a small bit of coolant dripping out of this hole on the casing over the waterpump(see picture 1) so I watched my coolant level and rode home, but as I started going the hole started to piss a lot more coolant a lot quicker. So I brought it home called the local bike shop and browsed the forum, came to the conclusion I'd order a new waterpump bearing, seal, impeller, the small piece that holds the impeller in place and the circlip for infront of the impeller, water pump gasket and cover gasket. Installed everything while being careful not to puncture the seal and got it all back together but had forgotten to tighten the farthest left middle bolt on the case all the way so there was the tiniest bit of slack so it started to leak out of the bottom of the case...but it was coolant mixed with oil coming out . Did I not press the seal in far enough or where did I go wrong and where do I go from here, sorry for the short story but I did it all rushed so I can make it to a close friends memorial cruise on the 24th and hoping I can have it fixed for then!
Attached Thumbnails
2008 FE550 Did I install the WP seal wrong?-img_1393.jpg  
Taygen is offline  
 
Reply

  Husaberg Forum > Mechanical and Technical > Cooling Systems

Tags
2008, fe550, install, seal, wrong



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: 2008 FE550 like new emskou Classifieds 2 September 28th, 2016 11:50 AM
2007 fe550 kick star, gear selector seal sickd Mechanical 5 July 5th, 2015 08:27 PM
570 waterpump seal is wrong wthemechanic Cooling Systems 1 July 23rd, 2012 04:41 PM
WHICH WAY TO INSTALL WATER PUMP SEAL? scisneros Cooling Systems 1 February 1st, 2011 07:12 AM
2008 water pump seal leak fasteddy Cooling Systems 11 December 6th, 2008 09:14 PM


Facebook Twitter Google+ RSS Feed