Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Cooling Systems

Cooling Systems Cooling Systems - Radiators, Water Pumps, Fans, Coolant, etc.


Reply
 
LinkBack Thread Tools Display Modes
May 30th, 2016, 12:01 PM   #1
Junior Member
 
Joined: May 2016
From: USA

Posts: 12
Thanks: 3

I Ride: 2010 Husaberg FE450
Weep hole leaking?

I changed the water pump cover seal and now it's losing coolant really quick. It's dribbling out. Went for a ride around the block to warm it up and see what would happened, when I came back it was violently spitting the coolant out of the hole... I didn't touch the seal inside the impeller so what's going on? Any ideas? Thanks in advance!

It's a 2010 FE450

EDIT: The impeller bolt was loose, Tightened that down and then found that one of the pump cover screws was stripped. The actual threads were stripped. So I go to drill it out and put a helacoil in. My dad was doing the drilling and ended up drilling right through. So now I get to take the entire bike apart, take the engine out, take the case to a machinist to fix it. Anyone have any tips on getting the engine out?

Last edited by fallenmoons; May 30th, 2016 at 02:45 PM.
fallenmoons is offline  
 
May 30th, 2016, 11:21 PM   #2
Senior Member
 
Joined: Nov 2011
From: Nordic countries

Posts: 1,060
Thanks: 488

I Ride: Two FE570 -12
To get the engine out you more or less have to disassemble the complete bike... Take pictures of the looms routing while you disassemble everything.
jon andersson is offline  
May 31st, 2016, 04:39 PM   #3
Senior Member
 
FE350's Avatar
 
Joined: Apr 2014
From: Chilliwack, BC, Canada

Posts: 686
Thanks: 252

I Ride: 2014 FE350, Beautiful Blonde
You could first try JB WELD. Clean out the hole fill with JB Weld re drill with a drill stop this time. Tap with bottoming tap to length. Might be worth a shot ???

Another idea ? Tap the hole and screw in small set screw to depth with JB WELD on it then clean hole with bottoming tap.
FE350 is offline  
June 11th, 2016, 05:21 PM   #4
Junior Member
 
Joined: May 2016
From: USA

Posts: 12
Thanks: 3

I Ride: 2010 Husaberg FE450
Okay. So update. The bike is back together, ended up using a helacal for the threads than just JB welding the back to keep the oil from coming out. Seems to work good. Still having the problem with the coolant. Whenever the bike is running it just spits out coolant out the weep hole, aggressively. No oil, just water.

Also my clutch slave cylinder is leaking magura blood. It didn't do this before, why now? I replaced the master cylinder plunger because the old one was leaking at the pivot point but the clutch still isnt fully disengaging. Could be because there's still air in the line but my bleed screw is stripped so I have to just keep pumping it until I get the air out.

Any ideas on the weep hole? I've found a lot of info on how/what to fix if there's oil coming out but nothing on just coolant.
fallenmoons is offline  
June 11th, 2016, 07:27 PM   #5
Senior Member
 
FE350's Avatar
 
Joined: Apr 2014
From: Chilliwack, BC, Canada

Posts: 686
Thanks: 252

I Ride: 2014 FE350, Beautiful Blonde
If you can pump up pressure than you have air, I have had success forcing the air out via the pumping procedure. I have also released the banjo bolt at the lever and topped up fluid as it drained out, then tightened the banjo and pumped vigorously until pressure came allowing the air to come out the master reservoir. I can not help you on the weep hole but have seen many threads on this, so I am sure you will find the answer snooping around.
FE350 is offline  
September 9th, 2018, 08:40 AM   #6
Junior Member
 
Joined: Aug 2018
From: South africa

Posts: 1
Thanks: 0

I Ride:
have u managed to sort the weap hole I have the same issue on my 05 450
Jarred is offline  
September 10th, 2018, 12:39 AM   #7
ede
Senior Member
 
ede's Avatar
 
Joined: Jul 2015
From: Germany

Posts: 124
Thanks: 103

I Ride: Husaberg FE 501 2002
@Jarred:
I don't know what "fallenmoons" did to his bike, but the 2010 and the 2005 are different stories.

About your 2005 weephole issue: Get a new shaft seal ring for the waterpump shaft AND a new O-Ring, that belongs on that shaft, AND the bearing for the waterpumpshaft, with the rubber-cap on it. If your waterpump shaft isn't worn, this should be the cure!

Regards,
EDE
ede is offline  
September 10th, 2018, 12:55 AM   #8
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,439
Thanks: 401

I Ride: Husaberg FE501e 2003
I make up a kit fort the 2004-2008s.
https://www.ebay.co.uk/itm/Husaberg-...item3d71221867

and this one for the 2001-2003
https://www.ebay.co.uk/itm/Husaberg-...item3b192738f7

cheers

taffy
Taffy is offline  
September 10th, 2018, 12:55 AM   #9
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,439
Thanks: 401

I Ride: Husaberg FE501e 2003
I make up a kit fort the 2004-2008s.
https://www.ebay.co.uk/itm/Husaberg-...item3d71221867

and this one for the 2001-2003
https://www.ebay.co.uk/itm/Husaberg-...item3b192738f7

cheers

taffy
Taffy is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Cooling Systems

Tags
hole, leaking, weep



Search tags for this page
Click on a term to search for related topics.
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Weep Hole Oil Leaking with new seal and bearing Blamir Cooling Systems 10 December 8th, 2017 04:11 AM
Weep hole leaking oil Mackberg Mechanical 35 May 16th, 2013 05:48 AM
The weep hole pollo Mechanical 5 September 20th, 2009 09:08 PM
New 2008 550 FE Weep Hole leaking oil? fasteddy Mechanical 16 March 7th, 2009 05:35 PM
Water leaking from weep hole whats needed to fix? wpeteman Mechanical 15 January 4th, 2009 06:23 PM


Facebook Twitter Google+ RSS Feed