Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Cooling Systems

Cooling Systems Cooling Systems - Radiators, Water Pumps, Fans, Coolant, etc.


Reply
 
LinkBack Thread Tools Display Modes
March 22nd, 2014, 10:41 PM   #1
Junior Member
 
Joined: Aug 2013
From: Adelaide

Posts: 3
Thanks: 0

I Ride:
2009 FE450 water pump

Hi,

Yes i've read the seemingly endless threads on this weep hole issue but i'm still not quite sure what needs replacing?

I replaced the water seal but then i boiled the bike in some really tight single track and it boiled and flooded out of the weephole. I've checked it again and it seems that the new seal has been worn slightly leaving grainy rubber residue on the oil seal. Is this a sign that the shaft bearing needs to be replaced and if so i presume i need new oil and water seal? There is freeplay on the water pump impellor also so i assume this is also past it's use by date?

Pic's attached.

Any help appreciated

cheers

Jamie

[attachment=0:1u13qxse]1-20140309_161502.jpg[/attachment:1u13qxse]

seal residue?

[attachment=0:1u13qxse]1-20140309_161502.jpg[/attachment:1u13qxse]

old seal and new seal showing wear
Attached Thumbnails
2009 FE450 water pump-1-20140309_161502.jpg  
cybertoothtiger is offline  
 
March 22nd, 2014, 10:57 PM   #2
Senior Member
 
berglsmerg's Avatar
 
Joined: Aug 2009
From: Charters Towers, Australia

Posts: 1,296
Thanks: 344

I Ride: FE 610 oh yea
Re: 2009 FE450 water pump

So just make sure;

Is your radiator cap good
Is your vent hose free of obstruction or restrictions
Have you fitted the coolant seal the right way ? ( does the spring garter face the impeller )
Is the pump shaft grooved on the sealing area ?
Are you sure you haven't donea head gasket ?

Can you be more specific about the play you describe ?
berglsmerg is offline  
March 23rd, 2014, 06:48 PM   #3
Junior Member
 
Joined: Aug 2013
From: Adelaide

Posts: 3
Thanks: 0

I Ride:
Re: 2009 FE450 water pump

Originally Posted by berglsmerg
So just make sure;

Is your radiator cap good - YES
Is your vent hose free of obstruction or restrictions - YES
Have you fitted the coolant seal the right way ? ( does the spring garter face the impeller ) - YES
Is the pump shaft grooved on the sealing area ? - NO
Are you sure you haven't donea head gasket ? - HOW CAN I TELL? There is no oil in the water and vice versa and no sign of leaks externally.

Can you be more specific about the play you describe ? - with the impellor on the shaft there is about 5mm of 'free play' rotation when moving the impellor by hand, the shaft itself does not move
Answers in quote above.

Cheers, J
cybertoothtiger is offline  
March 26th, 2014, 03:46 PM   #4
Senior Member
 
berglsmerg's Avatar
 
Joined: Aug 2009
From: Charters Towers, Australia

Posts: 1,296
Thanks: 344

I Ride: FE 610 oh yea
Re: 2009 FE450 water pump

Sometimes with the engine at operating temp, with the rad cap off you might observe some small bubbles in the coolant or some oil/hydrocarbon staining. Also you can have the coolant tested.

If your seals rad cap etc etc are fine and you still have lots of coolant gushing out of the weep hole then I'd say yor HG is toast.
berglsmerg is offline  
October 14th, 2014, 06:48 AM   #5
Junior Member
 
Joined: Feb 2012
From: Finland, Italy, Germany

Posts: 9
Thanks: 0

I Ride:
Quite amazing to me that the biggest bike company cannot figure out which way the seals go. Embarrassing?!
tkyyro is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Cooling Systems

Tags
2009, fe450, pump, water



Search tags for this page
Click on a term to search for related topics.
Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
2010, FE450, how to chg water pump seals? digbyn Cooling Systems 3 August 14th, 2015 09:52 PM
Water pump loses water after thousands of replacements.. Leyf Cooling Systems 6 October 7th, 2013 02:06 AM
04 FE450 Water pump impeller shredded, Misterberg Cooling Systems 3 July 24th, 2011 11:25 PM
Water pump impeller dimension required - 04 FE450 rojerk Mechanical 2 October 31st, 2008 09:02 PM
i have water oil mix coming from hole next to water pump? yardster Mechanical 4 January 22nd, 2008 04:26 AM


Facebook Twitter Google+ RSS Feed