Husaberg
Go Back   Husaberg Forum > Mechanical and Technical > Cooling Systems

Cooling Systems Cooling Systems - Radiators, Water Pumps, Fans, Coolant, etc.


Reply
 
LinkBack Thread Tools Display Modes
July 13th, 2013, 06:16 AM   #1
Junior Member
 
Joined: Jun 2013
From:

Posts: 3
Thanks: 0

I Ride:
Water pump loses water after thousands of replacements..

Hey! My water pump still leaks cooland after i replaced the head gasket, the foot gasket and everything from the water pump. I got a 570 FE from 09 and it leaks coolant since 50hrs and now im at 70.. Anybody help?
Leyf is offline  
 
July 14th, 2013, 05:03 AM   #2
Senior Member
 
berglsmerg's Avatar
 
Joined: Aug 2009
From: Charters Towers, Australia

Posts: 1,292
Thanks: 341

I Ride: FE 610 oh yea
Re: Water pump loses water after thousands of replacements..

Did you check the seals are in the correct way ? Some 09's came with them in back to front and it's easy to put new seals in just like the factory did, you want the two springs facing away from each other.
There is also a weep hole mod that keeps the goom out of the area between the two seal, sometimes the goom can hurt the sealing area of the pump shaft.

Did you surface the head and cylinder when doing the gaskets ? Did you use mls or copper head gasket ? And do you get little bubbles in your radiator with the cap off ?

It's a very frustrating thing hope this helps.
berglsmerg is offline  
July 14th, 2013, 06:50 AM   #3
Junior Member
 
Joined: Jun 2013
From:

Posts: 3
Thanks: 0

I Ride:
Re: Water pump loses water after thousands of replacements..

Hey i replaced them in the right way.

I think i used a copper gasket and i surfaced them beofore i used them. No i dont get any bubbles :/
Leyf is offline  
October 2nd, 2013, 06:00 AM   #4
Junior Member
 
Joined: Sep 2012
From: Greece

Posts: 19
Thanks: 3

I Ride: FE390
Re: Water pump loses water after thousands of replacements..

hi
i had leakage from the weep hole and the overflow radiator hose. Replaced the radiator cap with new. Problem solved.
toulioss is offline  
October 3rd, 2013, 02:16 AM   #5
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,463
Thanks: 408

I Ride: Husaberg FE501e 2003
Re: Water pump loses water after thousands of replacements..

the factory do a repair kit. a lot of people don't realise the coolant is coming from a weep hole and not around the hose clip which is what it initially looks like?

Taffy
Taffy is offline  
October 6th, 2013, 01:58 PM   #6
Junior Member
 
Joined: Sep 2012
From: Greece

Posts: 19
Thanks: 3

I Ride: FE390
Re: Water pump loses water after thousands of replacements..

is it normal tho, to lose all the time liquid from the weephole?
toulioss is offline  
October 7th, 2013, 02:06 AM   #7
Senior Member
 
Joined: Nov 2001
From: Ely, England

Posts: 15,463
Thanks: 408

I Ride: Husaberg FE501e 2003
Re: Water pump loses water after thousands of replacements..

of course not!

Taffy
Taffy is offline  
Reply

  Husaberg Forum > Mechanical and Technical > Cooling Systems

Tags
loses, pump, replacements, thousands, water



Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
water pump pin keith450 Husaberg 2 December 14th, 2012 07:57 AM
upgraded water pump impeller, and oil pump?? bulgarian Husaberg 2 April 22nd, 2011 08:54 AM
i have water oil mix coming from hole next to water pump? yardster Mechanical 4 January 22nd, 2008 04:26 AM
Leaking Water Pump Fix Kit cafey18 Cooling Systems 33 July 15th, 2007 06:59 AM
Assembly of water pump risky1 Mechanical 12 June 25th, 2005 03:45 PM


Facebook Twitter Google+ RSS Feed