Husaberg Forum

Husaberg Forum (http://husaberg.org/husaberg-forums.php)
-   Cooling Systems (http://husaberg.org/cooling-systems/)
-   -   Water Pump Seal Fix! (http://husaberg.org/cooling-systems/14130-water-pump-seal-fix.html)

jlburgess May 27th, 2011 02:19 PM

Water Pump Seal Fix!
 
The stock water pump seal failed on my bike at 3k miles. It's never been ridden in the dirt and the shaft was found to be grooved, so a new seal didn't fix it.

Found Kawasaki part # 92049-0104 seal will fit and is 1mm deeper, moving the sealing area away from the damaged area on the shaft. Looks like a winner for the next guy that this happens to.

jzfe May 28th, 2011 11:57 AM

Re: Water Pump Seal Fix!
 
Good job! Keep us posted on long term reliability.

ElSnorro May 29th, 2011 11:43 PM

Re: Water Pump Seal Fix!
 
Great info dude, will try this.

DaleEO May 30th, 2011 08:53 PM

Re: Water Pump Seal Fix!
 
Great find!

I moved your topic from the general forum to the cooling forum and made it a sticky since there have been many posts concerning this issue.

Dale

sparks May 31st, 2011 07:49 AM

Re: Water Pump Seal Fix!
 
Quote:

Originally Posted by jlburgess
The stock water pump seal failed on my bike at 3k miles. It's never been ridden in the dirt and the shaft was found to be grooved, so a new seal didn't fix it.

Found Kawasaki part # 92049-0104 seal will fit and is 1mm deeper, moving the sealing area away from the damaged area on the shaft. Looks like a winner for the next guy that this happens to.


Don't forget to use antifreeze coolant, this also aids as a lubricant for the seal and should prolong the wear to the shaft also.
Unless you ride SM on the circuit where you can only use water.

Regards

Sparks.

heydon November 18th, 2011 11:26 AM

Re: Water Pump Seal Fix!
 
Quote:

Originally Posted by jlburgess
The stock water pump seal failed on my bike at 3k miles. It's never been ridden in the dirt and the shaft was found to be grooved, so a new seal didn't fix it.

Found Kawasaki part # 92049-0104 seal will fit and is 1mm deeper, moving the sealing area away from the damaged area on the shaft. Looks like a winner for the next guy that this happens to.

I had the same problem with my Fe 550, Fitted one new seal and it still leaked!!
When we looked at the shaft with the side casing on there was room for two seals, (Only shows One in the manual) So we fitted two and it has stoped the leak!!

zaga November 21st, 2011 12:52 AM

Re: Water Pump Seal Fix!
 
Hi jlburgess

Could you give me the dimensions of the seal.

I have the same problem in a 01 bike and would like to know if its the same size.

:cheers:
ZAGA

ebayy1229 November 21st, 2011 12:48 PM

Re: Water Pump Seal Fix!
 
OMGG I REALLY HOPE THIS WORKS! i just did a rebuild on my bike new piston, ring, sleeve, rod etc. nd i always had a coolant prob with it, so i also installed a new water pump shaft, seals, n the o-ring. but coolant is still dripping out of that little hole by the water pump, and it even mixed with oil when i started it up :(

zaga November 22nd, 2011 08:08 AM

Re: Water Pump Seal Fix!
 
1 Attachment(s)
Hi

If you changed everything and didn't worked, try this heat shrink sleeve, when you install the cover before you ruin another seal:

[attachment=0:20qt2hkd]Sleeve.jpg[/attachment:20qt2hkd]

:cheers:
ZAGA

shoey85 December 9th, 2011 08:01 PM

Re: Water Pump Seal Fix!
 
i am having this exact problem right now, i am going to try 2 seals


All times are GMT -8. The time now is 05:25 AM.

Copyright © 2018 Husaberg Forum. All rights reserved.